classification
Title: Warning -- multiprocessing.process._dangling was modified by test_multiprocessing
Type: Stage: resolved
Components: Tests Versions: Python 3.2, Python 3.3
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: georg.brandl, ned.deily, pitrou, sbt
Priority: normal Keywords:

Created on 2011-08-18 00:21 by ned.deily, last changed 2012-06-19 13:35 by sbt. This issue is now closed.

Messages (3)
msg142295 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2011-08-18 00:21
[188/352] test_multiprocessing
Warning -- multiprocessing.process._dangling was modified by test_multiprocessing
msg142296 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2011-08-18 00:28
This warning is a regression in 3.2.2 from previous 3.2 releases due to the dangling Thread and Process checks added to 3.2 by 64e35f3bcda5 for Issue12573; the same checks introduce a new warning in 3.2.2 for test_threaded_import which has already been fixed in default but not backported to 3.2.
msg162403 - (view) Author: Richard Oudkerk (sbt) * (Python committer) Date: 2012-06-06 12:09
The warning no longer appears for the 3.x branch.  I think it was changeset e54adf13e7a6 which only modified the test suite.  

I don't think it is worth backporting to 3.2.
History
Date User Action Args
2012-06-19 13:35:17sbtsetstatus: pending -> closed
2012-06-06 12:09:19sbtsetstatus: open -> pending

nosy: + sbt
messages: + msg162403

resolution: fixed
stage: needs patch -> resolved
2011-08-18 00:29:32ned.deilysetnosy: + georg.brandl, pitrou
2011-08-18 00:28:02ned.deilysetmessages: + msg142296
2011-08-18 00:21:16ned.deilycreate