classification
Title: ConfigParser.__init__(iterpolation=None) documentation != behavior
Type: behavior Stage:
Components: Library (Lib) Versions:
process
Status: closed Resolution: duplicate
Dependencies: Superseder: ConfigParser(interpolation=None) doesn't work
View: 11324
Assigned To: Nosy List: lukasz.langa, zildjohn01
Priority: normal Keywords:

Created on 2011-08-03 21:18 by zildjohn01, last changed 2011-08-03 22:15 by lukasz.langa. This issue is now closed.

Files
File name Uploaded Description Edit
patch.txt zildjohn01, 2011-08-03 21:18 Bugfix patch
Messages (2)
msg141615 - (view) Author: John Simon (zildjohn01) Date: 2011-08-03 21:18
The ConfigParser docs say that when __init__ is called with interpolation=None, no interpolation occurs. But when this is done in Python 3.2.1, it actually results in an AttributeError upon getting or setting a value, due to self._interpolation being set to None.

This incredibly simple patch brings the behavior inline with the docs.
msg141616 - (view) Author: Ɓukasz Langa (lukasz.langa) * (Python committer) Date: 2011-08-03 22:15
Hey there! Thanks for your report. However:

1. this is a duplicate of #11324

2. AFAICT this is corrected in 3.2.1 (3.2.0 had the bug). Just downloaded the source distribution from python.org, it is indeed fixed.
History
Date User Action Args
2011-08-03 22:15:27lukasz.langasetstatus: open -> closed
resolution: duplicate
superseder: ConfigParser(interpolation=None) doesn't work
messages: + msg141616
2011-08-03 21:27:00r.david.murraysetnosy: + lukasz.langa
2011-08-03 21:18:46zildjohn01create