classification
Title: argparse - document (and improve?) use of SUPPRESS with help=
Type: enhancement Stage: needs patch
Components: Documentation, Library (Lib) Versions: Python 3.3
process
Status: closed Resolution: duplicate
Dependencies: Superseder: document argparse's help=SUPPRESS
View: 9349
Assigned To: docs@python Nosy List: bethard, derks, docs@python, petri.lehtinen, r.david.murray
Priority: normal Keywords: easy

Created on 2011-08-03 07:23 by derks, last changed 2012-10-18 16:38 by bethard. This issue is now closed.

Messages (5)
msg141601 - (view) Author: BJ Dierkes (derks) Date: 2011-08-03 07:23
Having the ability to 'hide' positional/option arguments and subparsers in argparse would be useful.  For example, I might want to add a subparser for 'somecommand-help' which would be a commands specifically for displaying help output of 'somecommand'.  There is no reason I'd want to display this as an available argument... but rather simply add to the description "For more info try <command>-help".

Something like:

parser = argparse.ArgumentParser()
sub = parser.add_subparsers()
somecommand_help = sub.add_parser('somecommand-help', hide=True)

OR

parser.add_argument('--some-crazy-option', hide=True).


It would then not display in the '--help' output, but would still function when 'somecommand-help' or '--some-crazy-option' is passed at command line.  Would also be an extra bonus to add some sort of interface to 'list_hidden_arguments').
msg141609 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2011-08-03 12:30
This is partly a doc issue, but there also appear to be bugs in the way the existing functionality works (although it is hard to tell for sure since it isn't documented :)

Try using the value argparse.SUPPRESS as the value of help= in various places and you'll see what I mean.
msg149541 - (view) Author: Steven Bethard (bethard) * (Python committer) Date: 2011-12-15 12:19
Could you give some examples of bugs that you observed? Otherwise, this looks like a duplicate of issue 9349.

The intention is that help=SUPPRESS should cause the given argument to not be displayed in the help message. If there are cases where that's not true, then it's definitely a bug.
msg173281 - (view) Author: Petri Lehtinen (petri.lehtinen) * (Python committer) Date: 2012-10-18 16:04
Can this be closed?
msg173283 - (view) Author: Steven Bethard (bethard) * (Python committer) Date: 2012-10-18 16:38
Yeah, looks like we can close this. If anyone finds a specific bug in the use of SUPPRESS, please open a new issue.
History
Date User Action Args
2012-10-18 16:38:21bethardsetstatus: open -> closed
superseder: document argparse's help=SUPPRESS
resolution: duplicate
messages: + msg173283
2012-10-18 16:04:09petri.lehtinensetnosy: + petri.lehtinen
messages: + msg173281
2011-12-15 12:19:31bethardsetmessages: + msg149541
2011-08-03 12:30:58r.david.murraysetassignee: docs@python

components: + Documentation, Library (Lib), - None
title: argparse - add 'hide' feature -> argparse - document (and improve?) use of SUPPRESS with help=
keywords: + easy
nosy: + r.david.murray, docs@python, bethard
versions: + Python 3.3
messages: + msg141609
stage: needs patch
2011-08-03 07:23:40derkscreate