classification
Title: Implement `os.startfile` under Linux and Mac
Type: Stage:
Components: Library (Lib) Versions: Python 3.3
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: cool-RR, ezio.melotti, rosslagerwall
Priority: normal Keywords:

Created on 2011-07-09 11:59 by cool-RR, last changed 2011-07-12 06:36 by ezio.melotti. This issue is now closed.

Messages (2)
msg140057 - (view) Author: Ram Rachum (cool-RR) * Date: 2011-07-09 11:59
I want to use `os.startfile` to open a folder in Explorer/Nautilus/Finder. The documentation says that it's only implemented on Windows:

http://docs.python.org/dev/library/os.html#os.startfile

See discussion on Python-ideas here:
https://groups.google.com/forum/?hl=en#!topic/python-ideas/LL0SavbKrEA


Is there a good reason why `os.startfile` is implemented only on Windows?
msg140058 - (view) Author: Ross Lagerwall (rosslagerwall) (Python committer) Date: 2011-07-09 12:13
I think this is a duplicate of #3177.
History
Date User Action Args
2011-07-12 06:36:26ezio.melottisetnosy: + ezio.melotti
2011-07-09 12:13:13rosslagerwallsetstatus: open -> closed

nosy: + rosslagerwall
messages: + msg140058

resolution: duplicate
2011-07-09 11:59:05cool-RRcreate