classification
Title: Restrict Google search to docs when in the docs subtree?
Type: behavior Stage:
Components: Documentation Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: loewis, skip.montanaro
Priority: normal Keywords:

Created on 2007-09-27 19:27 by skip.montanaro, last changed 2008-01-06 15:31 by georg.brandl. This issue is now closed.

Messages (4)
msg56179 - (view) Author: Skip Montanaro (skip.montanaro) * (Python triager) Date: 2007-09-27 19:27
It was reported to webmaster@python.org today that Thomas Heller's
pyhelp.cgi script is not available (yields 403 Forbidden).  For the
time being I removed that link from http://www.python.org/doc/.
Still, there is the Google search box at the top of the page.  Alas,
that only restricts the search to www.python.org.  It would be nice if
on those pages under the /doc/... tree the relevant parameter
(sitesearch?) restricted the search to the doc tree.  Can this be done
easily?

(On a related note, shouldn't the website be listed as a separate
component in the classification section?)
msg56185 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2007-09-28 04:37
Website issues are not tracked in this tracker. See

http://wiki.python.org/moin/PythonWebsiteCreatingNewTickets
msg56191 - (view) Author: Skip Montanaro (skip.montanaro) * (Python triager) Date: 2007-09-28 16:33
Martin> Website issues are not tracked in this tracker. See
    Martin> http://wiki.python.org/moin/PythonWebsiteCreatingNewTickets

Is there some reason at this point that we need to maintain two separate
trackers?  A ton of work went into making our Roundup instance what the key
players wanted.  Why not use it to track website issues as well?  With them
separate you have two communities of maintainers and triage folks who are
mostly disjoint.

I assume there would be some trac-to-roundup conversion necessary.  Perhaps
something like that already exists.

Skip
msg56195 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2007-09-28 21:03
> Is there some reason at this point that we need to maintain two separate
> trackers? 

I don't know - I explained what is, not what should be. Whether or not
pydotorg people want to use the tracker, I can't tell.

Regards,
Martin
History
Date User Action Args
2008-01-06 15:31:34georg.brandlsetstatus: open -> closed
resolution: not a bug
2007-09-28 21:03:15loewissetmessages: + msg56195
2007-09-28 16:33:17skip.montanarosetmessages: + msg56191
2007-09-28 04:37:49loewissetnosy: + loewis
messages: + msg56185
2007-09-27 19:27:17skip.montanarocreate