classification
Title: test_signal.test_without_siginterrupt() failure on AMD64 OpenIndiana 3.x
Type: Stage:
Components: Versions: Python 3.3
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: jcea, pitrou, vstinner
Priority: normal Keywords:

Created on 2011-05-12 23:02 by vstinner, last changed 2012-10-01 23:04 by vstinner. This issue is now closed.

Messages (3)
msg135882 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-05-12 23:02
test_signal fails sometimes on the "AMD64 OpenIndiana 3.x" buildbot:

Traceback (most recent call last):
  File "/export/home/buildbot/64bits/3.x.cea-indiana-amd64/build/Lib/test/test_signal.py", line 358, in test_without_siginterrupt
    self.assertTrue(i)
AssertionError: False is not true

http://www.python.org/dev/buildbot/all/builders/AMD64%20OpenIndiana%203.x/builds/1188/steps/test/logs/stdio

This failure may be related to my recent work on signals, see #8407.
msg135923 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-05-13 16:12
I'm unable to reproduce the issue using regrtest.py -F test_signal. It is maybe a race condition, or another test has a border effect of test_signal?
msg171757 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2012-10-01 23:04
I didn't see this issue recently, 'm unable to reproduce it, so I close this issue.
History
Date User Action Args
2012-10-01 23:04:29vstinnersetstatus: open -> closed
resolution: works for me
messages: + msg171757
2011-05-13 16:12:09vstinnersetmessages: + msg135923
2011-05-13 01:08:00jceasetnosy: + jcea
2011-05-12 23:02:46vstinnercreate