classification
Title: AttributeError: 'module' object has no attribute 'scipy'
Type: behavior Stage:
Components: Tests Versions: Python 3.1
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: alex, alex_lai
Priority: normal Keywords:

Created on 2011-05-08 17:17 by alex_lai, last changed 2011-05-08 17:18 by alex. This issue is now closed.

Messages (2)
msg135533 - (view) Author: Alex Lai (alex_lai) Date: 2011-05-08 17:17
Hi experts,
  I'm new to Python. I've just successfully compiled and installed NumPy and SciPy. When I run the tests, Numpy shows no issues:

# python3 -c "import numpy; numpy.test()"
Running unit tests for numpy
NumPy version 1.5.1
NumPy is installed in /usr/local/lib/python3.1/site-packages/numpy
Python version 3.1.2 (r312:79147, Mar 23 2010, 02:42:06) [GCC 3.4.6]
nose version 1.0.0

----------------------------------------------------------------------
Ran 0 tests in 0.027s


  However, test for Scipy gave the following error:

# python3 -c "import numpy; import scipy; numpy.scipy()"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
AttributeError: 'module' object has no attribute 'scipy'

  Any idea what might be missing here?

Thanks in advance,

Alex
msg135535 - (view) Author: Alex Gaynor (alex) * (Python committer) Date: 2011-05-08 17:18
This bug tracker is for filing bugs in Python itself, for support with 3rd party libraries you should try their mailing lists or IRC channels.
History
Date User Action Args
2011-05-08 17:18:44alexsetstatus: open -> closed

nosy: + alex
messages: + msg135535

resolution: not a bug
2011-05-08 17:17:02alex_laicreate