classification
Title: test_multiprocessing failure on "AMD64 OpenIndiana 3.x": KeyError on id_to_obj[ident] in serve_client()
Type: Stage:
Components: Library (Lib) Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: vstinner
Priority: normal Keywords:

Created on 2011-04-20 21:22 by vstinner, last changed 2011-12-09 13:00 by vstinner. This issue is now closed.

Messages (2)
msg134184 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-04-20 21:22
[129/354] test_multiprocessing
Process Process-72:
Traceback (most recent call last):
  File "/export/home/buildbot/64bits/3.x.cea-indiana-amd64/build/Lib/multiprocessing/process.py", line 263, in _bootstrap
    self.run()
  File "/export/home/buildbot/64bits/3.x.cea-indiana-amd64/build/Lib/multiprocessing/process.py", line 118, in run
    self._target(*self._args, **self._kwargs)
  File "/export/home/buildbot/64bits/3.x.cea-indiana-amd64/build/Lib/test/test_multiprocessing.py", line 799, in _test_event
    event.set()
  File "/export/home/buildbot/64bits/3.x.cea-indiana-amd64/build/Lib/multiprocessing/managers.py", line 1009, in set
    return self._callmethod('set')
  File "/export/home/buildbot/64bits/3.x.cea-indiana-amd64/build/Lib/multiprocessing/managers.py", line 776, in _callmethod
    raise convert_to_error(kind, result)
multiprocessing.managers.RemoteError: 
---------------------------------------------------------------------------
Traceback (most recent call last):
  File "/export/home/buildbot/64bits/3.x.cea-indiana-amd64/build/Lib/multiprocessing/managers.py", line 245, in serve_client
    obj, exposed, gettypeid = id_to_obj[ident]
KeyError: '4e17d80'
---------------------------------------------------------------------------
test test_multiprocessing failed -- Traceback (most recent call last):
  File "/export/home/buildbot/64bits/3.x.cea-indiana-amd64/build/Lib/test/test_multiprocessing.py", line 831, in test_event
    self.assertEqual(wait(), True)
  File "/export/home/buildbot/64bits/3.x.cea-indiana-amd64/build/Lib/test/test_multiprocessing.py", line 98, in __call__
    return self.func(*args, **kwds)
  File "/export/home/buildbot/64bits/3.x.cea-indiana-amd64/build/Lib/multiprocessing/managers.py", line 1013, in wait
    return self._callmethod('wait', (timeout,))
  File "/export/home/buildbot/64bits/3.x.cea-indiana-amd64/build/Lib/multiprocessing/managers.py", line 776, in _callmethod
    raise convert_to_error(kind, result)
multiprocessing.managers.RemoteError: 
---------------------------------------------------------------------------
Traceback (most recent call last):
  File "/export/home/buildbot/64bits/3.x.cea-indiana-amd64/build/Lib/multiprocessing/managers.py", line 245, in serve_client
    obj, exposed, gettypeid = id_to_obj[ident]
KeyError: '4e17d80'
---------------------------------------------------------------------------
http://www.python.org/dev/buildbot/all/builders/AMD64%20OpenIndiana%203.x/builds/1025/steps/test/logs/stdio
msg149090 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-12-09 13:00
I didn't see this failure again since the issue was opened, so I close it as invalid.
History
Date User Action Args
2011-12-09 13:00:21vstinnersetstatus: open -> closed
resolution: not a bug
messages: + msg149090
2011-04-20 21:22:51vstinnercreate