classification
Title: PY_CFLAGS and PY_CPPFLAGS inconsistent
Type: behavior Stage: resolved
Components: Distutils Versions: Python 3.2, Python 3.3
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: tarek Nosy List: benjamin.peterson, eric.araujo, jcea, pitrou, ronaldoussoren, serhiy.storchaka, steve.dower, tarek
Priority: high Keywords:

Created on 2011-03-18 18:47 by pitrou, last changed 2021-02-03 18:37 by steve.dower. This issue is now closed.

Messages (4)
msg131354 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-03-18 18:47
One contains the include dirs for Python, not the other:

>>> distutils.sysconfig.get_config_var('PY_CFLAGS')
'-g -O0 -Wall -Wstrict-prototypes'
>>> distutils.sysconfig.get_config_var('PY_CPPFLAGS')
'-I. -IInclude -I./Include'

In Python 2.7 and 3.1, PY_CFLAGS did contain the include dirs, so this seems to be a regression:

>>> distutils.sysconfig.get_config_var('PY_CFLAGS')
'-g -O2 -g -Wall -Wstrict-prototypes -I. -IInclude -I./Include  -DPy_BUILD_CORE'
msg132122 - (view) Author: √Čric Araujo (eric.araujo) * (Python committer) Date: 2011-03-25 17:45
Ditto for sysconfig.
msg162869 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2012-06-15 08:15
PY_CFLAGS (C compiler flags) always used with PY_CPPFLAGS (C preprocessor flags). The include directories need for #include, so it is logical that PY_CPPFLAGS did contain them. This may be useful if you use C preprocessor without C compiler. I don't think that this is a regression.
msg386441 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2021-02-03 18:37
Distutils is now deprecated (see PEP 632) and all tagged issues are being closed. From now until removal, only release blocking issues will be considered for distutils.

If this issue does not relate to distutils, please remove the component and reopen it. If you believe it still requires a fix, most likely the issue should be re-reported at https://github.com/pypa/setuptools
History
Date User Action Args
2021-02-03 18:37:36steve.dowersetstatus: open -> closed

nosy: + steve.dower
messages: + msg386441

resolution: out of date
stage: needs patch -> resolved
2012-06-15 08:15:19serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg162869
2011-03-25 17:45:03eric.araujosetnosy: + jcea, ronaldoussoren, benjamin.peterson
messages: + msg132122
2011-03-18 18:47:17pitroucreate