classification
Title: Python 3.2 input() does not remove "\r" at the end of returned string.
Type: behavior Stage: resolved
Components: Windows Versions: Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder: input() has trailing carriage return on windows
View: 11272
Assigned To: Nosy List: Trundle, jaylogan
Priority: normal Keywords:

Created on 2011-03-07 17:22 by jaylogan, last changed 2011-03-07 17:30 by r.david.murray. This issue is now closed.

Messages (2)
msg130265 - (view) Author: Joshua Logan (jaylogan) Date: 2011-03-07 17:22
Hello,

It is mentioned in the documentation for input() ( http://docs.python.org/py3k/library/functions.html#input ) that the newline is stripped from the end of the returned string. However, on Windows, it used to trim '\r\n'. Now it no longer trims '\r'.

See output below:

C:\>python
Python 3.2 (r32:88445, Feb 20 2011, 21:29:02) [MSC v.1500 32 bit (Intel)] on win32

>>> name = input("What's your name? ")
What's your name? Josh
>>> print(name)
Josh
>>> print(list(name))
['J', 'o', 's', 'h', '\r']
msg130266 - (view) Author: Andreas Stührk (Trundle) * Date: 2011-03-07 17:23
This is a duplicate of issue #11272.
History
Date User Action Args
2011-03-07 17:30:43r.david.murraysetstatus: open -> closed
nosy: jaylogan, Trundle
superseder: input() has trailing carriage return on windows
resolution: duplicate
stage: resolved
2011-03-07 17:23:50Trundlesetnosy: + Trundle
messages: + msg130266
2011-03-07 17:22:22jaylogancreate