classification
Title: Python 2.7.1 cannot be built by 2.x baselines of Python
Type: compile error Stage:
Components: Build Versions: Python 2.7, Python 2.6, Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: barry, pitrou, w004dal
Priority: normal Keywords:

Created on 2011-02-28 16:31 by w004dal, last changed 2011-02-28 16:37 by pitrou. This issue is now closed.

Messages (2)
msg129712 - (view) Author: David (w004dal) Date: 2011-02-28 16:31
I tried to download and install the latest Python tarball (2.7.1) and use Python 2.6 to execute "setup.py".

I got the error "No module named sysconfig" when running setup.py. "sysconfig" was introduced with Python 3.2 (per http://docs.python.org/dev/library/sysconfig.html).

I am running Ubuntu 10.04.2 LTS and Python 2.6 trying to update to 2.7.x since Django does not support Python 3.x. It seems like a lot of trouble to install Python 3.x to downgrade to the Python version I need.

Recommend providing deb source packages that can be built on Ubuntu 10.04 and 10.10, or fixing this bug.
msg129713 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-02-28 16:37
The way to build Python is to run "./configure" followed by "make". This is explained in the README.
History
Date User Action Args
2011-02-28 16:37:06pitrousetstatus: open -> closed

nosy: + barry, pitrou
messages: + msg129713

resolution: not a bug
2011-02-28 16:31:56w004dalcreate