classification
Title: OpenSSL detection broken for Python 3.0a1
Type: compile error Stage:
Components: Build Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: georg.brandl, pythonmeister
Priority: normal Keywords:

Created on 2007-09-07 18:41 by pythonmeister, last changed 2007-09-07 21:07 by georg.brandl. This issue is now closed.

Messages (3)
msg55739 - (view) Author: Stefan Sonnenberg-Carstens (pythonmeister) Date: 2007-09-07 18:41
In line 618 the comparison must be this:

if (openssl_ver >= 0x00908000):

otherwise there are complaints about not being able to build
the _sha256 and _sha512 modules, even if OpenSSL >= 0.9.8 is installed,
as in my case.
msg55741 - (view) Author: Stefan Sonnenberg-Carstens (pythonmeister) Date: 2007-09-07 20:08
Patch attached:

--- setup.py    2007-09-07 16:08:05.000000000 -0400
+++ ../Python-3.0a1_SSC/setup.py        2007-09-07 16:07:31.000000000 -0400
@@ -613,7 +613,7 @@
         else:
             missing.append('_hashlib')

-        if (openssl_ver < 0x00908000):
+        if (openssl_ver >= 0x00908000):
             # OpenSSL doesn't do these until 0.9.8 so we'll bring our
own hash
             exts.append( Extension('_sha256', ['sha256module.c']) )
             exts.append( Extension('_sha512', ['sha512module.c']) )
msg55744 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2007-09-07 21:07
I think you misunderstood the setup.py message; from OpenSSL 0.9.8, building
the _sha modules is not needed.  That they are reported as not built is a
bug which has been fixed now in SVN.
History
Date User Action Args
2007-09-07 21:07:29georg.brandlsetstatus: open -> closed
nosy: + georg.brandl
messages: + msg55744
resolution: not a bug
2007-09-07 20:08:46pythonmeistersetmessages: + msg55741
2007-09-07 18:41:13pythonmeistercreate