classification
Title: "make altinstall" installs pydoc, idle, smtpd.py with broken shebang lines
Type: crash Stage:
Components: Build Versions: Python 3.0
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: dripton, georg.brandl
Priority: normal Keywords:

Created on 2007-09-06 22:06 by dripton, last changed 2007-09-12 19:29 by georg.brandl. This issue is now closed.

Messages (2)
msg55714 - (view) Author: David Ripton (dripton) Date: 2007-09-06 22:06
Gentoo Linux, x86, Python 3.0a

I did a vanilla "./configure; make; make test; make altinstall" build.

The following files were created in /usr/local/bin:
-rwxr-xr-x 1 root root   18036 Sep  6 17:49 smtpd.py
-rwxr-xr-x 1 root root      81 Sep  6 17:49 pydoc
-rwxr-xr-x 1 root root      96 Sep  6 17:49 idle
-rwxr-xr-x 1 root root 3644316 Sep  6 17:58 python3.0
-rwxr-xr-x 1 root root    1401 Sep  6 17:59 python3.0-config

As intended, altinstall does not create /usr/local/bin/python, so
"python" is still the pre-existing python2.5.

However, other binaries are installed as though /usr/local/bin/python
were created, so they don't work.

dripton@al ~ $ pydoc
bash: /usr/local/bin/pydoc: /usr/local/bin/python: bad interpreter: No
such file or directory
dripton@al ~ $ idle
bash: /usr/local/bin/idle: /usr/local/bin/python: bad interpreter: No
such file or directory
dripton@al ~ $ smtpd.py
bash: /usr/local/bin/smtpd.py: /usr/local/bin/python: bad interpreter:
No such file or directory

Suggest that "make altinstall" should not put anything in the bin
directory except pythonX.Y and pythonX.Y-config, which are "safe"
because of the embedded version numbers.  Another option would be
installing those other binaries but with fixed shebang lines.
msg55862 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2007-09-12 19:29
Fixed in rev. 58125, should be merged to 3k shortly. Thanks!
History
Date User Action Args
2009-04-06 10:49:23ajaksu2linkissue1590 dependencies
2007-09-12 19:29:48georg.brandlsetstatus: open -> closed
resolution: fixed
messages: + msg55862
nosy: + georg.brandl
2007-09-06 22:06:50driptoncreate