classification
Title: hashlib module fails with TypeError
Type: crash Stage:
Components: Library (Lib) Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: dripton, georg.brandl
Priority: normal Keywords:

Created on 2007-09-06 10:54 by dripton, last changed 2007-09-06 13:49 by georg.brandl. This issue is now closed.

Messages (2)
msg55687 - (view) Author: David Ripton (dripton) Date: 2007-09-06 10:54
The hashlib module seems not to work at all:

$ python3.0
Python 3.0a1 (py3k, Sep  5 2007, 08:17:11)
[GCC 4.1.2 (Gentoo 4.1.2)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import hashlib
>>> m = hashlib.md5()
>>> m.update("Nobody inspects")
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
TypeError: object supporting the buffer API required

(Same error with hashlib.sha1(), etc.)
msg55691 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2007-09-06 13:49
David Ripton schrieb:
> New submission from David Ripton:
> 
> The hashlib module seems not to work at all:
> 
> $ python3.0
> Python 3.0a1 (py3k, Sep  5 2007, 08:17:11)
> [GCC 4.1.2 (Gentoo 4.1.2)] on linux2
> Type "help", "copyright", "credits" or "license" for more information.
>>>> import hashlib
>>>> m = hashlib.md5()
>>>> m.update("Nobody inspects")
> Traceback (most recent call last):
>   File "<stdin>", line 1, in <module>
> TypeError: object supporting the buffer API required

hashlib only accepts bytes for its digests, since the algorithms work
on bytes, not characters.

Unfortunately, this isn't documented yet, but I'll do that now.
History
Date User Action Args
2007-09-06 13:49:56georg.brandlsetstatus: open -> closed
nosy: + georg.brandl
messages: + msg55691
resolution: not a bug
2007-09-06 10:54:57driptoncreate