classification
Title: python 2.6.6 and python 2.7.1 cannot be built successfully because of an segment fault on NetBSD-5.1-sparc
Type: compile error Stage: resolved
Components: Build Versions: Python 2.7, Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: NetBSD: segmentation fault in listextend during install
View: 7424
Assigned To: Nosy List: loewis, skrah, vstinner, xuhdev
Priority: normal Keywords:

Created on 2011-02-03 17:31 by xuhdev, last changed 2011-02-04 05:43 by xuhdev. This issue is now closed.

Messages (5)
msg127802 - (view) Author: Hong Xu (xuhdev) Date: 2011-02-03 17:31
Build python 2.6.6 and python 2.7.1 on a NetBSD-5.1-sparc machine.

1. Run './configure';
2. Run 'make';
3. Run 'make install'.

There will be a problem after run 'make install'.
The last few lines of error messages are like the following:

Compiling /usr/local/lib/python2.6/test/test_binop.py ...
Compiling /usr/local/lib/python2.6/test/test_bisect.py ...
Compiling /usr/local/lib/python2.6/test/test_bool.py ...
Compiling /usr/local/lib/python2.6/test/test_bsddb.py ...
Compiling /usr/local/lib/python2.6/test/test_bsddb185.py ...
Compiling /usr/local/lib/python2.6/test/test_bsddb3.py ...
Compiling /usr/local/lib/python2.6/test/test_buffer.py ...
Compiling /usr/local/lib/python2.6/test/test_bufio.py ...
Compiling /usr/local/lib/python2.6/test/test_builtin.py ...
[1]   Segmentation fault (core dumped) PYTHONPATH=/usr/...
*** Error code 139

Stop.
make: stopped in /home/xuh/src/Python-2.6.6

Same thing with python 2.7.1.
msg127823 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2011-02-03 21:20
Can you debug this, e.g. by inspecting the core file?
msg127824 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-02-03 21:24
Can you try to get a backtrace? Use make install SHELL="bash -x" to display executed shell commands. And then rerun the last command in gdb: after the crash, the "where" command will give you a backtrace.
msg127826 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2011-02-03 22:28
This seems to be a duplicate of #7424.
msg127870 - (view) Author: Hong Xu (xuhdev) Date: 2011-02-04 05:43
The result of 'make install SHELL="bash -x"' seems nothing different with the "make install". Could there be any other way to debug?
History
Date User Action Args
2011-02-04 05:43:12xuhdevsetnosy: loewis, vstinner, skrah, xuhdev
messages: + msg127870
2011-02-03 22:28:50skrahsetstatus: open -> closed

superseder: NetBSD: segmentation fault in listextend during install

nosy: + skrah
messages: + msg127826
resolution: duplicate
stage: resolved
2011-02-03 21:24:04vstinnersetnosy: + vstinner
messages: + msg127824
2011-02-03 21:20:16loewissetnosy: + loewis
messages: + msg127823
2011-02-03 17:31:10xuhdevcreate