classification
Title: Need some setup.py sanity
Type: enhancement Stage: resolved
Components: Build Versions: Python 3.3, Python 3.4, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Mac OS X: building with X11 Tkinter
View: 1584
Assigned To: tarek Nosy List: barry, eric.araujo, mforbes, ned.deily, tarek, terry.reedy
Priority: normal Keywords:

Created on 2005-01-26 04:28 by skip.montanaro, last changed 2013-11-12 08:05 by ned.deily. This issue is now closed.

Messages (5)
msg24052 - (view) Author: Skip Montanaro (skip.montanaro) * (Python triager) Date: 2005-01-26 04:28
Python's setup.py has grown way out of control.  I'm
trying to build and install Python 2.4.0 on a Solaris
system with Tcl/Tk installed in a non-standard place and
I can't figure out the incantation to tell setup.py to look
where they are installed.  I have tried:

  * setting LDFLAGS and CPPFLAGS on the make and
  configure command lines

  * running "setup.py --help" and "setup.py build --help"

  * reading the setup.py source

It's not at all obvious to me from any of this if there is
any way to point setup.py at a non-standard place.

Over time setup.py has grown into the Python
equivalent of a configure script, but there's been
precious little refactoring, so there is stuff all over the
place to add this directory on that platform or try
different ad hoc solutions for various external packages
based upon common installation practices.  I think it's
time to rethink the function and organization of setup.py.

This might be an excellent sprint topic for PyCon.
msg24053 - (view) Author: Michael Forbes (mforbes) Date: 2007-03-28 11:12
Something like this works with Python 2.5
./configure LDFLAGS="-L/myplace/tcl8.4.14_gcc/lib/"\
                  CPPFLAGS="-I/myplace/tcl8.4.14_gcc/include/"

(Both tcl and tk librarys and headers are installed in these directories.)

msg109681 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2010-07-09 04:51
Skip, did the suggestion work? or is this otherwise out of date for 3.2?
msg121404 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-11-18 01:25
The bug reported by Skip looks like something to be done with ./configure.  When this is solved, I think this bug with its original title should be kept open.  Let’s refactor setup.py into something manageable and testable.
msg202677 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2013-11-12 08:05
Issue1584 has implemented ways to specify non-standard Tcl and Tk include file and library locations, both via ./configure and as "make" arguments.  Since there are many other issues open regarding specific aspects of setup.py and since, in nine years, there has has been no progress in addressing the more general concerns and since the intent is to phase out setup.py in general in future releases, I am going to close this issue as a duplicate of Issue1584.
History
Date User Action Args
2013-11-12 08:05:23ned.deilysetstatus: open -> closed

superseder: Mac OS X: building with X11 Tkinter
versions: + Python 2.7, Python 3.3, Python 3.4, - Python 3.2
nosy: + ned.deily

messages: + msg202677
resolution: duplicate
stage: resolved
2010-11-18 01:25:26eric.araujosetmessages: + msg121404
2010-11-12 01:12:31eric.araujosetnosy: + barry
2010-07-31 20:42:18eric.araujosetnosy: + eric.araujo
2010-07-09 04:51:23terry.reedysetnosy: + terry.reedy

messages: + msg109681
versions: + Python 3.2, - Python 2.5
2010-05-20 20:26:40skip.montanarosetnosy: - skip.montanaro
2009-02-11 02:56:55ajaksu2setassignee: tarek
type: enhancement
nosy: + tarek
2005-01-26 04:28:21skip.montanarocreate