classification
Title: Runtime error
Type: crash Stage:
Components: Windows Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, yelenawu
Priority: normal Keywords:

Created on 2011-02-01 23:16 by yelenawu, last changed 2011-02-02 09:47 by amaury.forgeotdarc. This issue is now closed.

Files
File name Uploaded Description Edit
test2 yelenawu, 2011-02-01 23:16 my script (edited out some private info)
Messages (2)
msg127711 - (view) Author: Yelena (yelenawu) Date: 2011-02-01 23:16
I've been using python to run some large database recently. 
I used dbfpy module to access some information stored in dbf format.
However, after 20hrs of running it gave me an error of :
Runtime Error!
This application has requested the Runtime to terminate it in an unusual way.Please contact the application's support team for more information.

The error popped out every time I ran them after 20 hrs. My prediction was that
it ran over its memory usage, since it has been accumulating the memory usage
when I was running the program. So I tried deleting/closing I/O immediately
after they were processed. However, such changes did not make any difference
in memory usage accumulation.

Could you please give me some advice in fixing problems like this?

Thank you.
msg127730 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2011-02-02 09:47
For this kind of question you'd better ask on the comp.lang.python newsgroup. The bug tracker is not designed to get help.

A remark though: to really debug the RuntimeError a C debugger is needed (and a debug build of Python). You'd better try to know why your script consumes more and more memory. There are certainly tools for this, and people on the python newsgroup will be happy to share them with you.
History
Date User Action Args
2011-02-02 09:47:27amaury.forgeotdarcsetstatus: open -> closed

nosy: + amaury.forgeotdarc
messages: + msg127730

resolution: not a bug
2011-02-01 23:16:23yelenawucreate