classification
Title: test_capi crashes and fails
Type: crash Stage: resolved
Components: Tests, Windows Versions: Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_capi.test_no_FatalError_infinite_loop crash on Windows
View: 9116
Assigned To: Nosy List: brian.curtin, rmtew
Priority: normal Keywords:

Created on 2011-01-30 02:56 by rmtew, last changed 2011-01-30 02:58 by brian.curtin. This issue is now closed.

Messages (2)
msg127512 - (view) Author: (rmtew) Date: 2011-01-30 02:56
OS: Windows 7
Compiler: Visual Studio 2008
Build: Win32 (Debug and Release)

The main problem is observed in both debug and release builds, and even though the test effectively passes in both it also fails in release build.

** In a debug build I see the following:

  test_instancemethod (__main__.CAPITest) ... ok
  test_no_FatalError_infinite_loop (__main__.CAPITest) ...

Then a dialog pops up telling me that Python has crashed.  The unit test execution pauses until this dialog is dealt with.  This then becomes:

  test_no_FatalError_infinite_loop (__main__.CAPITest) ... ok

And the unit tests proceed to pass.

** In a release build I see the following:

  test_instancemethod (__main__.CAPITest) ... ok
  test_no_FatalError_infinite_loop (__main__.CAPITest) ...

Then the crash dialog also pops up.  Dismissing it results in the test failing however.

  test_no_FatalError_infinite_loop (__main__.CAPITest) ... FAIL

  ======================================================================
  FAIL: test_no_FatalError_infinite_loop (__main__.CAPITest)
  ----------------------------------------------------------------------
  Traceback (most recent call last):
    File "Lib\test\test_capi.py", line 50, in test_no_FatalError_infinite_loop
      b'Fatal Python error:'
  AssertionError: b"Fatal Python error: PyThreadState_Get: no current thread\n\r\nThis application has requested the Runtime to terminate it in an unusual way.\nPlease contact the application's support team for more information." != b'Fatal Python error: PyThreadState_Get: no current thread'

Is there some information I am missing somewhere (that I have not found via googling) or is this part of the gauntlet of unit test execution on Python now?
msg127513 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2011-01-30 02:57
Duplicate of #9116.
History
Date User Action Args
2011-01-30 02:58:11brian.curtinsetversions: + Python 3.2, - Python 3.1
2011-01-30 02:57:56brian.curtinsetstatus: open -> closed

superseder: test_capi.test_no_FatalError_infinite_loop crash on Windows
versions: + Python 3.1, - Python 3.2
nosy: + brian.curtin

messages: + msg127513
resolution: duplicate
stage: resolved
2011-01-30 02:56:03rmtewcreate