classification
Title: Mercurial fails on code.python.org repo
Type: behavior Stage:
Components: Versions: Python 2.7
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: pitrou, sdaoden
Priority: normal Keywords:

Created on 2011-01-29 12:42 by sdaoden, last changed 2011-01-30 16:17 by pitrou. This issue is now closed.

Messages (7)
msg127408 - (view) Author: Steffen Daode Nurpmeso (sdaoden) Date: 2011-01-29 12:42
... because i don't know where to place this message, i do place it here.
Whatever has happened in the last 90 minutes, cloning from code.python.org/hg results in mercurial panics!
Please see http://mercurial.selenic.com/bts/issue2239 for more on that.
Have a nice weekend.
msg127410 - (view) Author: Steffen Daode Nurpmeso (sdaoden) Date: 2011-01-29 12:46
MAN!! Forget it - it's ok again; it's maybe really a mercurial non-atomicity failure.
msg127411 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-01-29 12:48
Works fine here.
msg127412 - (view) Author: Steffen Daode Nurpmeso (sdaoden) Date: 2011-01-29 12:57
Nope.  In the meanwhile i've accomplished to clone py3k once again, but branches/release2.7-maint fails over and over again.  I've added another message to http://mercurial.selenic.com/bts/issue2239.
Have a nice weekend.
msg127541 - (view) Author: Steffen Daode Nurpmeso (sdaoden) Date: 2011-01-30 15:52
'Had to look on a sunday once again, and it is still impossible to clone branches/release2.7-maint.
In the meanwhile the Mercurial people from <http://mercurial.selenic.com> reacted - they play the ball back to python.org.
*However*: there are a lot of Issues at <http://mercurial.selenic.com/bts/issueXY> (try 2606, 2602, 2595, my 2239 and possibly others).
msg127543 - (view) Author: Steffen Daode Nurpmeso (sdaoden) Date: 2011-01-30 16:15
<http://mercurial.selenic.com/bts/issue2595> says "code.python.org/hg often seems unstable.", so it seems to be a well known thing.  I leave this issue now open nevertheless, and let some experienced Python.org user  decide what to do with it.  (Antoine Pitrou, you are nosy, and it seems i have completely missed your hint ("Works fine here" did not count for me) - will you close that as approbiate?)
msg127544 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-01-30 16:17
> 'Had to look on a sunday once again, and it is still impossible to
> clone branches/release2.7-maint.

It failed here on one attempt and succeeded on others. "hg verify" ran fine too, including on the server.

I'm closing the issue again; in all likelihood, this is either a transient network issue, or a Mercurial bug - and certainly not a bug in Python itself which is what this tracker is for ;)
History
Date User Action Args
2011-01-30 16:17:38pitrousetstatus: open -> closed
nosy: pitrou, sdaoden
messages: + msg127544
2011-01-30 16:15:58sdaodensetnosy: pitrou, sdaoden
messages: + msg127543
2011-01-30 15:52:54sdaodensetstatus: closed -> open
versions: + Python 2.7
nosy: pitrou, sdaoden
title: code.python.org repo failures introduced! -> Mercurial fails on code.python.org repo
messages: + msg127541
2011-01-29 12:57:37sdaodensetnosy: pitrou, sdaoden
messages: + msg127412
2011-01-29 12:48:39pitrousetresolution: works for me

messages: + msg127411
nosy: + pitrou
2011-01-29 12:46:14sdaodensetstatus: open -> closed
2011-01-29 12:46:05sdaodensetmessages: + msg127410
2011-01-29 12:42:38sdaodencreate