classification
Title: pep 227 missing text
Type: behavior Stage: resolved
Components: Documentation Versions:
process
Status: closed Resolution: later
Dependencies: Superseder:
Assigned To: docs@python Nosy List: BreamoreBoy, aisaac, cheryl.sabella, docs@python, eric.araujo, r.david.murray
Priority: normal Keywords:

Created on 2011-01-27 13:17 by aisaac, last changed 2018-01-26 00:05 by cheryl.sabella. This issue is now closed.

Messages (7)
msg127184 - (view) Author: Alan Isaac (aisaac) Date: 2011-01-27 13:17
In PEP 227 missing text is marked with XXX.  Most of this is just calls for examples and elaboration.  However under the Implementation section XXX marks a substantive question about the documentation.

Fixing this may be low priority, but a tracker search suggested it is currently not even being tracked ...
msg127451 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-01-29 17:48
This tracker is for reporting bugs found in the CPython distribution, not PEPs, PyPI or other websites.  You can write to the python-dev mailing list if the XXX bother you.
msg127533 - (view) Author: Alan Isaac (aisaac) Date: 2011-01-30 14:04
Bear with my confusion about your response.  Are you saying that CPython documentation bugs cannot be submitted here, or that this does not constitute a CPython documentation bug?  I assume the latter.  But then, can you tell me where to find the correct CPython documentation after I read the following quote from PEP 277?

http://www.python.org/dev/peps/pep-0227/
    "Implementation

    XXX Jeremy, is this still the case?

    The implementation for C Python uses flat closures [1]."

In case you might care about a user confusion ...  Your reply left me puzzled that PEPs that have reached the standards track would not be considered part of the CPython documentation distribution.

Thank you,
Alan Isaac
msg127616 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-01-31 16:46
The “Documentation” component is used for bugs found in files under the Doc directory of a CPython checkout or source tarball.  PEPs are tracked in their own repository and are not part of the CPython distribution.  They are not part of the docs.  Hope this clarifies things.
msg127640 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2011-01-31 18:41
Eric, what you say is technically true, but we don't have any other place to track PEP bugs.
msg228003 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-09-30 21:18
PEP 227 (Not 277 as wrongly quoted in one place) is about Statically Nested Scopes.  There are several XXX place holders in the current doc.  For all I know it would be possible to simply remove all of them, but who is best placed to give a definitive answer?
msg310721 - (view) Author: Cheryl Sabella (cheryl.sabella) * (Python triager) Date: 2018-01-26 00:05
Moved to the PEP issue tracker.
https://github.com/python/peps/issues/557
History
Date User Action Args
2018-01-26 00:05:50cheryl.sabellasetstatus: open -> closed

nosy: + cheryl.sabella
messages: + msg310721

resolution: later
stage: needs patch -> resolved
2014-09-30 21:18:58BreamoreBoysetnosy: + BreamoreBoy
messages: + msg228003
2011-01-31 18:41:41r.david.murraysetstatus: closed -> open

type: behavior
assignee: docs@python
components: + Documentation

nosy: + r.david.murray, docs@python
messages: + msg127640
resolution: not a bug -> (no value)
stage: resolved -> needs patch
2011-01-31 16:46:17eric.araujosetmessages: + msg127616
2011-01-30 14:04:59aisaacsetmessages: + msg127533
2011-01-29 17:48:24eric.araujosetstatus: open -> closed

type: enhancement -> (no value)
components: - Documentation
assignee: docs@python -> (no value)
nosy: + eric.araujo, - docs@python
messages: + msg127451
resolution: not a bug
stage: resolved
2011-01-27 13:17:12aisaaccreate