classification
Title: WinPE 64 bit execution results with errors
Type: enhancement Stage: resolved
Components: Build Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: BreamoreBoy, gettingback2basics, loewis, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2011-01-18 19:23 by gettingback2basics, last changed 2014-09-30 05:03 by tim.golden. This issue is now closed.

Messages (4)
msg126479 - (view) Author: Jeremy Langley (gettingback2basics) Date: 2011-01-18 19:23
old versions of python worked on old versions of winpe by copying the c:\python25\ directory over to the mounted (iso,usb) filesystem, then rebooting with the media and running the python.exe from the ramdrive.
This formula no longer works with 64 bit versions of winpe (which is one way to push win7-64bit.

When it's tried one gets platform based errors.
msg126484 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2011-01-18 19:35
Do you have any log files or screenshots of what exactly happens?

I have zero experience with WinPE, so that's an obvious barrier here, but there's also nothing to go by in figuring out where the problem may be.
msg126496 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2011-01-18 21:43
You need to install the MS CRT (msvcrt90.dll, along with its assembly manifests and stuff) as well; it's not surprising that copying over an installation doesn't work.

I'll also point out that this is not a bug: copying over an installation is not supposed to work.
msg227861 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-09-29 23:25
In msg126496 MVL says "I'll also point out that this is not a bug: copying over an installation is not supposed to work" so can we close this as "not a bug"?
History
Date User Action Args
2014-09-30 05:03:57tim.goldensetstatus: open -> closed
resolution: not a bug
stage: needs patch -> resolved
2014-09-29 23:25:09BreamoreBoysetnosy: + tim.golden, BreamoreBoy, zach.ware, steve.dower, - brian.curtin
messages: + msg227861
2011-01-18 21:43:52loewissetmessages: + msg126496
2011-01-18 19:35:28brian.curtinsetnosy: + brian.curtin

messages: + msg126484
stage: needs patch
2011-01-18 19:32:12pitrousetnosy: + loewis
2011-01-18 19:23:36gettingback2basicscreate