classification
Title: OS X 10.5.x Build Problems
Type: compile error Stage:
Components: Tests Versions: Python 3.0
process
Status: closed Resolution: duplicate
Dependencies: Superseder: cachersrc.py using tuple unpacking args
View: 1078
Assigned To: Nosy List: loewis, noahgift
Priority: normal Keywords:

Created on 2007-09-02 05:20 by noahgift, last changed 2007-09-02 07:15 by loewis. This issue is now closed.

Messages (2)
msg55575 - (view) Author: Noah Gift (noahgift) Date: 2007-09-02 05:44
Compile problem on:

System Software Overview:

  System Version:	Mac OS X 10.5 (9A527)
  Kernel Version:	Darwin 9.0.0b5

Temporary Fix was to go into Modules/posixmodule.c

and at line:  3767

Take out function and create empty function.

I was then able to get make to run, but still got these non-critical 
errors:

Failed to find the necessary bits to build these modules:
_bsddb            gdbm              ossaudiodev    
readline          spwd                             
To find the necessary bits, look in setup.py in detect_modules() for the 
module's name.


Failed to build these modules:
_OSA     

Running make test I get:

running sudo make test, some errors are:

Traceback (most recent call last):
  File "/Users/ngift/Desktop/Python-3.0a1/Lib/SocketServer.py", line 
222, in handle_request
    self.process_request(request, client_address)
  File "/Users/ngift/Desktop/Python-3.0a1/Lib/SocketServer.py", line 
241, in process_request
    self.finish_request(request, client_address)
  File "/Users/ngift/Desktop/Python-3.0a1/Lib/SocketServer.py", line 
254, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/Users/ngift/Desktop/Python-3.0a1/Lib/SocketServer.py", line 
522, in __init__
    self.handle()
  File "/Users/ngift/Desktop/Python-3.0a1/Lib/BaseHTTPServer.py", line 
330, in handle
    self.handle_one_request()
  File "/Users/ngift/Desktop/Python-3.0a1/Lib/BaseHTTPServer.py", line 
313, in handle_one_request
    self.raw_requestline = self.rfile.readline()
  File "/Users/ngift/Desktop/Python-3.0a1/Lib/io.py", line 380, in 
readline
    b = self.read(nreadahead())
  File "/Users/ngift/Desktop/Python-3.0a1/Lib/io.py", line 366, in 
nreadahead
    readahead = self.peek(1, unsafe=True)
  File "/Users/ngift/Desktop/Python-3.0a1/Lib/io.py", line 758, in peek
    current = self.raw.read(to_read)
  File "/Users/ngift/Desktop/Python-3.0a1/Lib/io.py", line 442, in read
    n = self.readinto(b)
  File "/Users/ngift/Desktop/Python-3.0a1/Lib/socket.py", line 292, in 
readinto
    return self._sock.recv_into(b)
socket.error: (35, 'Resource temporarily unavailable')
test test_xmlrpc failed -- errors occurred; run in verbose mode for 
details
test_xmlrpc_net
test_xmlrpc_net skipped -- Use of the `network' resource not enabled
test_zipfile
test_zipfile64
test_zipfile64 skipped -- test requires loads of disk-space bytes and a 
long time to run
test_zipimport
test_zlib
295 tests OK.
2 tests failed:
    test__locale test_xmlrpc
25 tests skipped:
    test_bsddb test_bsddb3 test_codecmaps_cn test_codecmaps_hk
    test_codecmaps_jp test_codecmaps_kr test_codecmaps_tw test_curses
    test_gdbm test_largefile test_locale test_normalization
    test_ossaudiodev test_pep277 test_socket_ssl test_socketserver
    test_ssl test_startfile test_timeout test_urllib2net
    test_urllibnet test_winreg test_winsound test_xmlrpc_net
    test_zipfile64
1 skip unexpected on darwin:
    test_ssl
make: *** [test] Error 1

Then when I run make install it *almost* works but I get:

Writing 
/Library/Frameworks/Python.framework/Versions/3.0/lib/python3.0/lib-
dynload/Python-3.0a1-py3.0.egg-info
ln -fs "../../../Python" 
"/Library/Frameworks/Python.framework/Versions/3.0/lib/python3.0/config/
libpython3.0.a"
cd Mac && make installmacsubtree DESTDIR=""
Creating directory 
/Library/Frameworks/Python.framework/Versions/3.0/Mac/Tools
DYLD_FRAMEWORK_PATH=/Users/ngift/Desktop/Python-3.0a1: ../python.exe 
./scripts/cachersrc.py -v 
/Library/Frameworks/Python.framework/Versions/3.0/lib/python3.0/plat-mac 
/Library/Frameworks/Python.framework/Versions/3.0/Mac/Tools
  File "./scripts/cachersrc.py", line 15
    def handler((verbose, force), dirname, fnames):
                ^
SyntaxError: invalid syntax
make[1]: *** [installmacsubtree] Error 1
make: *** [frameworkinstallmaclib] Error 2
msg55578 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2007-09-02 07:15
This is a duplicate of #1078.
History
Date User Action Args
2007-09-02 07:15:32loewissetstatus: open -> closed
resolution: duplicate
superseder: cachersrc.py using tuple unpacking args
messages: + msg55578
nosy: + loewis
2007-09-02 05:44:38noahgiftsetnosy: + noahgift
messages: + msg55575
2007-09-02 05:20:15noahgiftcreate