classification
Title: intermittent test_cmd_line failure
Type: behavior Stage:
Components: Library (Lib) Versions: Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder: buildbot: test_cmd_line failure on Tiger: [Errno 9] Bad file descriptor
View: 8458
Assigned To: gregory.p.smith Nosy List: gregory.p.smith, ncoghlan, ned.deily, pitrou
Priority: normal Keywords:

Created on 2010-12-17 20:05 by pitrou, last changed 2010-12-18 21:16 by ned.deily. This issue is now closed.

Messages (2)
msg124254 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2010-12-17 20:05
It really looks like a subprocess issue:

======================================================================
ERROR: test_usage (test.test_cmd_line.CmdLineTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/buildbot/buildarea/3.x.parc-tiger-1/build/Lib/test/test_cmd_line.py", line 43, in test_usage
    rc, out, err = assert_python_ok('-h')
  File "/Users/buildbot/buildarea/3.x.parc-tiger-1/build/Lib/test/script_helper.py", line 50, in assert_python_ok
    return _assert_python(True, *args, **env_vars)
  File "/Users/buildbot/buildarea/3.x.parc-tiger-1/build/Lib/test/script_helper.py", line 30, in _assert_python
    env=env)
  File "/Users/buildbot/buildarea/3.x.parc-tiger-1/build/Lib/subprocess.py", line 721, in __init__
    self.stdin = io.open(p2cwrite, 'wb', bufsize)
OSError: [Errno 9] Bad file descriptor


See http://www.python.org/dev/buildbot/all/builders/PPC%20Tiger%203.x/builds/1213/steps/test/logs/stdio
msg124319 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-12-18 21:16
This is a duplicate of Issue8458. Merging the nosy lists.
History
Date User Action Args
2010-12-18 21:16:51ned.deilysetstatus: open -> closed

nosy: + ned.deily
messages: + msg124319

superseder: buildbot: test_cmd_line failure on Tiger: [Errno 9] Bad file descriptor
resolution: duplicate
2010-12-17 20:05:28pitroucreate