classification
Title: _scproxy extension is NOT build
Type: compile error Stage:
Components: Build, macOS, Tests Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: ronaldoussoren Nosy List: ned.deily, ronaldoussoren, vinp
Priority: normal Keywords:

Created on 2010-12-13 02:22 by vinp, last changed 2010-12-13 09:28 by ned.deily. This issue is now closed.

Messages (2)
msg123857 - (view) Author: Pierre Vinet (vinp) Date: 2010-12-13 02:22
From Python 2.7 http://www.python.org/ftp/python/2.7.1/Python-2.7.1.tar.bz2 released on November 27th, 2010.

At compile time :

 $ ../Python-2.7.1/configure --enable-framework
 $ make

we obtain within standard output:

building '_scproxy' extension
creating build/Python-2.7.1
creating build/Python-2.7.1/Mac
creating build/Python-2.7.1/Mac/Modules
/sw/lib/gcc4.2/bin/gcc -fno-strict-aliasing -fno-common -dynamic -O2 -Wall -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I/Users/vinp/Documents/informatique/python/installation/version-2.7.1/Python-2.7.1/Mac/Include -I. -IInclude -I../Python-2.7.1/Include -I/sw/include -I/opt/macports/include -I/opt/include -I/usr/X11R6/include -I/usr/include -I/usr/local/include -I/Users/vinp/Documents/informatique/python/installation/version-2.7.1/Python-2.7.1/Include -I/Users/vinp/Documents/informatique/python/installation/version-2.7.1/objet_fwk -c ../Python-2.7.1/Mac/Modules/_scproxy.c -o build/temp.macosx-10.3-ppc-2.7/../Python-2.7.1/Mac/Modules/_scproxy.o
../Python-2.7.1/Mac/Modules/_scproxy.c: In function ‘get_proxy_settings’:
../Python-2.7.1/Mac/Modules/_scproxy.c:67: error: lvalue required as unary ‘&’ operand

Then the module _scproxy is not build, which yield to 35 tests crashes:
    test_SimpleHTTPServer test___all__ test_cgi test_codecmaps_cn
    test_codecmaps_hk test_codecmaps_jp test_codecmaps_kr
    test_codecmaps_tw test_cookielib test_distutils test_email
    test_email_codecs test_email_renamed test_httpservers test_mailbox
    test_mimetypes test_normalization test_old_mailbox test_pyclbr
    test_robotparser test_sax test_site test_smtplib test_smtpnet
    test_ssl test_sundry test_urllib test_urllib2
    test_urllib2_localnet test_urllib2net test_urllibnet test_wsgiref
    test_xml_etree test_xml_etree_c test_xmlrpc

$ uname -a
Darwin ts-77.rmkipqxaas02.globetrotter.net 8.11.0 Darwin Kernel Version 8.11.0: Wed Oct 10 18:26:00 PDT 2007; root:xnu-792.24.17~1/RELEASE_PPC Power Macintosh powerpc

Compiler gcc (GCC) is 4.2.4 (2007)

Thanks,

Pierre Vinet
msg123867 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-12-13 09:28
Building Python on OS X is currently only tested and supported using the gcc provided by Apple's Xcode Developer Tools (either gcc-4.0 for building on OS X 10.4 and 10.5 and gcc-4.2 or -4.0 for building on 10.6, depending on deployment target).  Also judging from the file paths shown, you've ended up with a mixture of Fink and MacPorts include file paths before the standard system ones, almost certainly a bad idea. Please reopen if the problem can be reproduced using Apple's gcc-4.0 for 10.4.
History
Date User Action Args
2010-12-13 09:28:40ned.deilysetstatus: open -> closed

nosy: + ned.deily
messages: + msg123867

resolution: not a bug
2010-12-13 02:22:19vinpcreate