classification
Title: Incorrect URL with webbrowser and firefox under Gnome
Type: behavior Stage:
Components: Library (Lib) Versions: Python 2.5
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: bingham, georg.brandl, orsenthil
Priority: normal Keywords:

Created on 2007-08-29 15:02 by bingham, last changed 2007-08-30 04:23 by orsenthil. This issue is now closed.

Messages (4)
msg55421 - (view) Author: Aaron Bingham (bingham) Date: 2007-08-29 15:02
Under Gnome, Firefox will open the wrong URL when launched by
webbrowser.  For example after running the following interactive session:

bingham@grizzly:~> python
Python 2.5.1 (r251:54863, Jun  6 2007, 13:42:30)
[GCC 4.1.2 20061115 (prerelease) (SUSE Linux)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import webbrowser
>>> webbrowser.open('http://www.python.org')
True

Firefox attempts to open the URL
file:///home/bingham/%22http://www.python.org%22.

This is caused by a bug in the Python standard library's webbrowser
module that only affects machines running Gnome.

On Gnome, webbrowser runs the command

gconftool-2 -g /desktop/gnome/url-handlers/http/command 2>/dev/null

to find the web browser, which prints out a browser command line like

/pkgs/Firefox/2.0/firefox "%s"

The quotes around "%s" are preserved when passing the command-line
arguments. The quotes prevent firefox from recognizing the URL and
firefox falls back to treating it as a file name. The webbrowser module
already handles extra quoting around the URL for the BROWSER environment
variable and this same treatment should be applied to the result of
gconftool-2.

The BROWSER environment variable issue, now fixed, is described at
http://bugs.python.org/issue1684254.  The present issue was discussed in
an Ubuntu bug report
(https://bugs.launchpad.net/ubuntu/+source/python2.5/+bug/83974) but was
not resolved.
msg55422 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2007-08-29 15:31
The current code in the 2.5 branch uses shlex.split to postprocess the
command line returned by gconftool too, so this should be already fixed.
msg55458 - (view) Author: Senthil Kumaran (orsenthil) * (Python committer) Date: 2007-08-30 04:22
I am on Fedora Core 3, gnome 2.6 and I am unable to reproduce this issue.
Could this be a Ubuntu configuration bug. Like adding " quotes after %s
for the firefox command?
msg55459 - (view) Author: Senthil Kumaran (orsenthil) * (Python committer) Date: 2007-08-30 04:23
Okay. I found the status later. It was fixed then with Python 2.6 which
I am using.
History
Date User Action Args
2007-08-30 04:23:04orsenthilsetmessages: + msg55459
2007-08-30 04:22:06orsenthilsetnosy: + orsenthil
messages: + msg55458
2007-08-29 15:31:52georg.brandlsetstatus: open -> closed
resolution: out of date
messages: + msg55422
nosy: + georg.brandl
2007-08-29 15:02:11binghamcreate