classification
Title: Wrong return type for xml.etree.ElementTree.parse()
Type: Stage: resolved
Components: Documentation Versions: Python 3.1, Python 3.2, Python 2.7, Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, tiwoc
Priority: normal Keywords:

Created on 2010-11-19 21:31 by tiwoc, last changed 2010-11-20 13:08 by eric.araujo. This issue is now closed.

Messages (2)
msg121571 - (view) Author: Daniel Seither (tiwoc) Date: 2010-11-19 21:31
Cite from http://docs.python.org/library/xml.etree.elementtree.html
> xml.etree.ElementTree.parse(source, parser=None)
>
> Parses an XML section into an element tree. source is a filename or
> file object containing XML data. parser is an optional parser
> instance. If not given, the standard XMLParser parser is used.
> Returns an ElementTree instance.

The last sentence should be "Returns an Element instance."

I verified this error for the Python versions as listed in this issue. In 2.5, the information was imprecise but correct.
msg121572 - (view) Author: Daniel Seither (tiwoc) Date: 2010-11-19 21:41
I need to read more accurately what is printed on my console... Forget about it.
History
Date User Action Args
2010-11-20 13:08:03eric.araujosetresolution: works for me -> not a bug
stage: resolved
2010-11-19 21:41:08tiwocsetstatus: open -> closed
resolution: works for me
messages: + msg121572
2010-11-19 21:32:41tiwocsettitle: Wrong return value for xml.etree.ElementTree.parse() -> Wrong return type for xml.etree.ElementTree.parse()
2010-11-19 21:31:55tiwoccreate