classification
Title: distutils.get_python_lib() returns /usr/local/python3/dist-packages on Ubuntu 10.10
Type: behavior Stage:
Components: Distutils Versions: Python 3.1
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Bruce.Sherwood, barry, eric.araujo, tarek
Priority: normal Keywords:

Created on 2010-10-26 05:33 by Bruce.Sherwood, last changed 2013-10-13 18:35 by georg.brandl. This issue is now closed.

Messages (3)
msg119590 - (view) Author: Bruce Sherwood (Bruce.Sherwood) Date: 2010-10-26 05:33
Using Python 3.1 installed on Ubuntu 10.10 from the package manager, distutils.get_python_lib() returns the nonexistent location /usr/local/python3/dist-packages instead of the correct location /usr/local/python3.1/dist-packages. This subversion bug is not present in distutils.get_python_inc(), which correctly returns /usr/include/python3.1.
msg119611 - (view) Author: Bruce Sherwood (Bruce.Sherwood) Date: 2010-10-26 15:47
Correction: distutils.get_python_lib() returns /usr/lib/python3/dist-packages (which does exist), while distutils.get_python_inc() returns /usr/include/python3.1. I don't understand the shadowy existence of some python3 files that are parallel to python3.1 files. But in any case, get_python_lib() and get_python_inc() are inconsistent with each other.
msg120814 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2010-11-08 22:24
This makes some sense (I think ;).  Include files are going to be tied specifically to the Python version but Python 3 packages are (with the addition of PEPs 3147 and 3149) sharable between Python 3 versions.  The plan IIUC is to backport those PEPs to Python 3.1 on Debian (and thus inherited by Ubuntu).

In any case, this is not a valid bug in Python because it's one area that Debian/Ubuntu makes distribution-specific changes to upstream.  See

http://wiki.debian.org/Python

and scroll down to "Deviations from upstream".  If there's an actual bug here (of which I'm not convinced ;) then it should be submitted at bugs.debian.org.
History
Date User Action Args
2013-10-13 18:35:24georg.brandlsetstatus: pending -> closed
2010-11-08 22:24:32barrysetstatus: open -> pending
resolution: not a bug
messages: + msg120814
2010-11-08 21:57:11eric.araujosetassignee: tarek ->

nosy: + barry
2010-10-26 15:47:11Bruce.Sherwoodsetmessages: + msg119611
2010-10-26 05:33:17Bruce.Sherwoodcreate