classification
Title: remove --with-wctype-functions configure option
Type: Stage: resolved
Components: Unicode Versions: Python 3.2
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: amaury.forgeotdarc Nosy List: amaury.forgeotdarc, eric.araujo, ezio.melotti, georg.brandl, lemburg
Priority: critical Keywords: patch

Created on 2010-07-09 09:15 by amaury.forgeotdarc, last changed 2010-09-12 22:43 by amaury.forgeotdarc. This issue is now closed.

Files
File name Uploaded Description Edit
kill-wctype.patch amaury.forgeotdarc, 2010-07-09 11:43 don't forget to regenerate "configure"
Messages (5)
msg109696 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2010-07-09 09:15
Quoting Marc-Andre Lemburg:
"""
The support for the wctype functions should have been remove long ago,
since they cause subtle incompatibilities between Python builds. I should
have probably never added it in the first place... people were worried
about the size of the type record tables at the time, which is why
I thought it would be a good idea to try to optionally use the C lib
functions.

The comment was true before the Python type tables were changed
into a type record database: the switch used to remove the
Python tables required for those functions. With the type records
database, this is no longer the case, since the records are also
being used for properties that are not exposed via wctype functions.
"""
msg109715 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2010-07-09 11:43
Patch attached.
msg109718 - (view) Author: Marc-Andre Lemburg (lemburg) * (Python committer) Date: 2010-07-09 11:54
Amaury Forgeot d'Arc wrote:
> 
> Amaury Forgeot d'Arc <amauryfa@gmail.com> added the comment:
> 
> Patch attached.

Thanks. The patch looks good and I'd be +1 on applying it.

The only problem I see is that we may have to follow the deprecation
process.

OTOH, I've announce the plan in 2004 and confirmed it again in 2005:

http://mail.python.org/pipermail/python-dev/2004-December/050193.html
http://mail.python.org/pipermail/python-dev/2005-April/052989.html
msg116118 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2010-09-11 20:43
I would say, go ahead and apply for 3.2.
msg116240 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2010-09-12 22:43
Applied in r84752.
History
Date User Action Args
2010-09-12 22:43:35amaury.forgeotdarcsetstatus: open -> closed
resolution: accepted -> fixed
messages: + msg116240

stage: resolved
2010-09-12 21:58:33amaury.forgeotdarcsetassignee: amaury.forgeotdarc
resolution: accepted
2010-09-11 21:59:30floxlinkissue9832 superseder
2010-09-11 20:45:11eric.araujosetnosy: + eric.araujo
2010-09-11 20:43:50georg.brandlsetpriority: normal -> critical
nosy: + georg.brandl
messages: + msg116118

2010-07-12 15:51:03pitroulinkissue1076790 superseder
2010-07-09 11:54:34lemburgsetmessages: + msg109718
2010-07-09 11:43:43amaury.forgeotdarcsetfiles: + kill-wctype.patch
keywords: + patch
messages: + msg109715
2010-07-09 09:15:15amaury.forgeotdarccreate