classification
Title: pybsddb 4.8.4 integration
Type: enhancement Stage: patch review
Components: Extension Modules Versions: Python 2.7
process
Status: closed Resolution: accepted
Dependencies: Superseder:
Assigned To: jcea Nosy List: Arfrever, jcea
Priority: normal Keywords:

Created on 2010-03-16 13:12 by jcea, last changed 2010-04-09 02:25 by jcea. This issue is now closed.

Messages (3)
msg101166 - (view) Author: Jesús Cea Avión (jcea) * (Python committer) Date: 2010-03-16 13:12
This issue tracks the progress of integration of pybsddb 4.8.3+ and centralize related discussion.

I have integrated all bsddb related patches until r78988, in pybsddb 4.8.3+, with the following caveats:

- The new code supports BDB 4.8, but drops support for 4.0. Berkeley DB 4.0 was released in 2001...

- Revert issue6949 (the 2.7 part). This integration work supercedes it.

- issue6462 is not integrated in pybsddb, but will be retained in the code integrated in python. I will try to resolve it in a permanent way after integration.

- issue3892 is not integrated in pybsddb, but will be retained in the code integrated in python. I will try to resolve it in a permanent way after integration.

- issue7975: I can't reproduce this bug with current pybsddb version. I will keep the patch around, but first integration test will not include it, unless we still can reproduce.

Some changes in bsddb testsuite require 2.7/3.2. I have decided to keep the changes, so I have to backport some code and use conditional execution, because I must support python 2.3-2.7 and 3.0-3.2.
msg101275 - (view) Author: Jesús Cea Avión (jcea) * (Python committer) Date: 2010-03-18 19:49
issue7975 finally reproduced. Solved in pybsddb 4.8.3+, and added relevant testcases.
msg101512 - (view) Author: Jesús Cea Avión (jcea) * (Python committer) Date: 2010-03-22 14:25
Integration committed as r79285.

The integration is with just released pybsddb 4.8.4, with patches for issue6462 and issue3892 added.
History
Date User Action Args
2010-04-09 02:25:37jceasetstatus: open -> closed
resolution: accepted
2010-03-22 14:25:57jceasetmessages: + msg101512
title: pybsddb 4.8.3+ integration -> pybsddb 4.8.4 integration
2010-03-18 21:02:20Arfreversetnosy: + Arfrever
2010-03-18 19:49:24jceasetmessages: + msg101275
2010-03-16 13:12:22jceacreate