classification
Title: Applets don't work on 10.1
Type: Stage:
Components: macOS Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: jackjansen Nosy List: akuchling, jackjansen
Priority: low Keywords:

Created on 2003-08-01 12:40 by jackjansen, last changed 2008-02-23 17:27 by akuchling. This issue is now closed.

Messages (2)
msg60364 - (view) Author: Jack Jansen (jackjansen) * (Python committer) Date: 2003-08-01 12:40
MacPython works fine on Mac OS X 10.1, except for one showstopper bug. I am filing this bug report so that we have all relevant information together in case someone feels like fixing it.

The problem is that our applets use a python script as their executable, with a #! first line pointing to Python. This works in 10.1 when run from the command line, but not when double-clicked from the finder.

A discussion on this can be found in the pythonmac-sig archives for Feb-2003, start with message <http://mail.python.org/pipermail/pythonmac-sig/2003-February/007328.html>.

With no applet support we have no IDE and no Package Manager, so there is little point in doing a binary installer unless someone fixes this.
msg62779 - (view) Author: A.M. Kuchling (akuchling) * (Python committer) Date: 2008-02-23 17:27
Presumably this was fixed in 10.1 or 10.2 at some point, because
MacPython 2.3 comes as an installer.  Closing as 'fixed'; Jack, please
re-open
if this is still relevant.
History
Date User Action Args
2008-02-23 17:27:34akuchlingsetstatus: open -> closed
resolution: fixed
messages: + msg62779
nosy: + akuchling
2003-08-01 12:40:15jackjansencreate