classification
Title: Build failure on OS X 10.5.5: make: *** [sharedmods] Error 1
Type: compile error Stage:
Components: Versions: Python 3.0, Python 3.1
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: mark.dickinson Nosy List: mark.dickinson, nelis
Priority: critical Keywords:

Created on 2008-12-07 21:59 by mark.dickinson, last changed 2008-12-08 16:13 by mark.dickinson. This issue is now closed.

Messages (3)
msg77267 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2008-12-07 21:59
There are two recent reports of build failures of Python 3.0 on OS X 
10.5.5: see

http://mail.python.org/pipermail/python-list/2008-November/514159.html

and

http://mail.python.org/pipermail/python-3000/2008-December/015404.html

It seems likely that these are related.  For both reports the build 
eventually fails with something like:

gcc  Python.framework/Versions/3.0/Python -o python.exe \
			Modules/python.o \
			 -ldl
make: *** [sharedmods] Error 1

I can reproduce this in the py3k branch and release30-maint branch on my 
Macbook by doing (at a Terminal prompt):

export LC_CTYPE="UTF-8"
./configure && make

I'll try to find time to look at this; any and all help welcomed!
msg77308 - (view) Author: nelis (nelis) Date: 2008-12-08 15:31
You asked how my locale looked, I've got:

10-92-86-47:Python-3.0 nelis$ locale
LANG=
LC_COLLATE="C"
LC_CTYPE="UTF-8"
LC_MESSAGES="C"
LC_MONETARY="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_ALL=

So I the LC_CTYPE is indeed UTF-8. I can also confirm that I can make if
I first run `export LC_CTYPE="nl_BE.UTF-8"' (the setting a friend of
mine has). I still get the following error, but I think it is unrelated
and I can ignore it and go on:

Failed to find the necessary bits to build these modules:
_gdbm              ossaudiodev        readline        
spwd

Afterwards I have been playing around with internationalization a bit,
trying to change the LC_CTYPE. Changing it to "United States
(Computer)", or to "Belgium (Dutch)" changed the other locale settings
to nl_be.UTF-8 but not the LC_CTYPE. The problem might be in OSX, but it
is still strange that this makes building in python impossible.
msg77317 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2008-12-08 16:13
Thanks for the information, nelis!

This appears to be a duplicate of issue 2173.  Further analysis should go 
there.
History
Date User Action Args
2008-12-08 16:13:35mark.dickinsonsetstatus: open -> closed
resolution: duplicate
messages: + msg77317
2008-12-08 15:31:28nelissetnosy: + nelis
messages: + msg77308
2008-12-07 21:59:51mark.dickinsoncreate