classification
Title: install_data.py does not record dirs
Type: enhancement Stage:
Components: Distutils Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: akuchling Nosy List: akuchling, jnelson
Priority: normal Keywords:

Created on 2001-07-25 20:31 by jnelson, last changed 2001-09-04 20:52 by jnelson. This issue is now closed.

Messages (5)
msg5612 - (view) Author: Jon Nelson (jnelson) Date: 2001-07-25 20:31
Let's say I want to create a directory but not put
anything in it. Logically, I would add:

data_files = [ ('directory', [] ) ],

to my setup.py file.

However, it doesn't work.
The following small patch allows special behavior for
empty file lists.  It is quite useful for normal
installs, as well as for bdist and friends.


--- install_data.py.orig        Wed Jul 25 15:27:19
2001
+++ install_data.py     Wed Jul 25 15:26:54 2001
@@ -63,6 +63,8 @@
                 elif self.root:
                     dir = change_root(self.root, dir)
                 self.mkpath(dir)
+               if f[1] == []:
+                       self.outfiles.append(dir)
                 for data in f[1]:
                     data = convert_path(data)
                     (out, _) = self.copy_file(data,
dir)


msg5613 - (view) Author: A.M. Kuchling (akuchling) * (Python committer) Date: 2001-09-04 20:42
Logged In: YES 
user_id=11375

Applied to revision 1.19 of 
distutils/commands/install_data.py.  Thanks!

msg5614 - (view) Author: Jon Nelson (jnelson) Date: 2001-09-04 20:51
Logged In: YES 
user_id=8446

Thanks!

This rocks.

Now, if I can only get an answer to 452144.
Of course, that's not a bug!
msg5615 - (view) Author: Jon Nelson (jnelson) Date: 2001-09-04 20:52
Logged In: YES 
user_id=8446

Uh oh.  Looks like a date problem somewhere.
Look at the 'close_date' field below:

1969-12-31 18:00

msg5616 - (view) Author: Jon Nelson (jnelson) Date: 2001-09-04 20:52
Logged In: YES 
user_id=8446

nevermind, it clearly means 'the dawn of time'.
History
Date User Action Args
2001-07-25 20:31:19jnelsoncreate