classification
Title: test_handle_called_with_mp_queue() of test_logging: threading_cleanup() failed to cleanup, on AMD64 FreeBSD 10.x Shared 3.x
Type: resource usage Stage: resolved
Components: Tests Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_logging leaks dangling threads on FreeBSD
View: 30830
Assigned To: Nosy List: haypo
Priority: normal Keywords: buildbot

Created on 2017-07-26 00:54 by haypo, last changed 2017-08-10 15:43 by haypo. This issue is now closed.

Messages (4)
msg299180 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-07-26 00:54
http://buildbot.python.org/all/builders/AMD64%20FreeBSD%2010.x%20Shared%203.x/builds/625/steps/test/logs/stdio

(...)
test_output (test.test_logging.UnixSocketHandlerTest) ... ok
test_output (test.test_logging.UnixDatagramHandlerTest) ... ok
test_output (test.test_logging.UnixSysLogHandlerTest) ... ok
test__all__ (test.test_logging.MiscTestCase) ... ok
test_handle_called_with_mp_queue (test.test_logging.QueueListenerTest) ... Warning -- threading_cleanup() failed to cleanup -1 threads after 4 sec (count: 0, dangling: 1)
ok
test_handle_called_with_queue_queue (test.test_logging.QueueListenerTest) ... ok
test_no_messages_in_queue_after_stop (test.test_logging.QueueListenerTest) ... ok
(...)

See also bpo-30830: "HTTPHandlerTest of test_logging leaks a "dangling" thread on AMD64 FreeBSD CURRENT Non-Debug 3.x".

Previously fixed warnings: bpo-30131.
msg299399 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-07-28 15:51
I ran "./python -m test -v test_logging --fail-env-changed -F" in 3 terminals on the FreeBSD 10 buildbot, and I failed to reproduce the bug. I ran my test for 5 minutes.

Maybe threading_cleanup() should call support.gc_collect().
msg300008 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-08-09 13:51
New fail:
http://buildbot.python.org/all/builders/AMD64%20FreeBSD%2010.x%20Shared%203.x/builds/680/steps/test/logs/stdio


test_handle_called_with_mp_queue (test.test_logging.QueueListenerTest) ... Warning -- threading_cleanup() failed to cleanup -1 threads after 3 sec (count: 0, dangling: 1)
ok
msg300107 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-08-10 15:43
Let's mark this issue as a duplicate of bpo-30830.
History
Date User Action Args
2017-08-10 15:43:31hayposetstatus: open -> closed
superseder: test_logging leaks dangling threads on FreeBSD
messages: + msg300107

resolution: duplicate
stage: resolved
2017-08-09 13:51:57hayposetmessages: + msg300008
2017-07-28 15:51:11hayposetmessages: + msg299399
2017-07-26 00:54:16hayposettitle: test_handle_called_with_mp_queue() of test_logging: threading_cleanup() failed to cleanup -> test_handle_called_with_mp_queue() of test_logging: threading_cleanup() failed to cleanup, on AMD64 FreeBSD 10.x Shared 3.x
2017-07-26 00:54:05haypocreate