classification
Title: [3.6] test_rapid_restart() of test_multiprocessing_fork fails randomly on AMD64 Debian PGO 3.6
Type: Stage: resolved
Components: Library (Lib) Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_multiprocessing_spawn and test_multiprocessing_forkserver leak dangling processes
View: 31069
Assigned To: Nosy List: davin, haypo
Priority: normal Keywords:

Created on 2017-07-04 11:10 by haypo, last changed 2017-08-16 08:46 by haypo. This issue is now closed.

Messages (3)
msg297641 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-07-04 11:10
http://buildbot.python.org/all/builders/AMD64%20Debian%20PGO%203.6/builds/517/steps/test/logs/stdio

======================================================================
ERROR: test_rapid_restart (test.test_multiprocessing_fork.WithProcessesTestManagerRestart)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/var/lib/buildbot/slaves/enable-optimizations-bot/3.6.gps-debian-profile-opt.nondebug/build/Lib/test/_test_multiprocessing.py", line 2410, in test_rapid_restart
    manager.start()
  File "/var/lib/buildbot/slaves/enable-optimizations-bot/3.6.gps-debian-profile-opt.nondebug/build/Lib/multiprocessing/managers.py", line 517, in start
    self._address = reader.recv()
  File "/var/lib/buildbot/slaves/enable-optimizations-bot/3.6.gps-debian-profile-opt.nondebug/build/Lib/multiprocessing/connection.py", line 250, in recv
    buf = self._recv_bytes()
  File "/var/lib/buildbot/slaves/enable-optimizations-bot/3.6.gps-debian-profile-opt.nondebug/build/Lib/multiprocessing/connection.py", line 407, in _recv_bytes
    buf = self._recv(4)
  File "/var/lib/buildbot/slaves/enable-optimizations-bot/3.6.gps-debian-profile-opt.nondebug/build/Lib/multiprocessing/connection.py", line 383, in _recv
    raise EOFError
EOFError
(...)
Re-running test 'test_multiprocessing_fork' in verbose mode
(...)
test_rapid_restart (test.test_multiprocessing_fork.WithManagerTestManagerRestart) ... ok
msg300136 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-08-10 23:58
See also bpo-31069.
msg300335 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-08-16 08:46
I'm not 100% sure that it's a duplicate of bpo-31069, but it's similar.
History
Date User Action Args
2017-08-16 08:46:19hayposetstatus: open -> closed
superseder: test_multiprocessing_spawn and test_multiprocessing_forkserver leak dangling processes
messages: + msg300335

resolution: duplicate
stage: resolved
2017-08-10 23:58:04hayposetmessages: + msg300136
2017-07-04 11:10:19hayposettitle: test_rapid_restart() of test_multiprocessing_fork fails randomly on AMD64 Debian PGO 3.6 -> [3.6] test_rapid_restart() of test_multiprocessing_fork fails randomly on AMD64 Debian PGO 3.6
2017-07-04 11:10:14haypocreate