classification
Title: Expat parser locks XML source file if ContentHandler raises an exception
Type: behavior Stage: resolved
Components: XML Versions: Python 3.1, Python 3.2, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: SAX parse (ExpatParser) leaks file handle when given filename input
View: 15388
Assigned To: Nosy List: BreamoreBoy, craigneuro, serhiy.storchaka
Priority: normal Keywords:

Created on 2008-05-12 19:44 by craigneuro, last changed 2013-02-05 20:06 by serhiy.storchaka. This issue is now closed.

Messages (3)
msg66754 - (view) Author: Craig Holmquist (craigneuro) Date: 2008-05-12 19:44
This was observed in Python 2.5.2 on Windows XP.  Run this code in IDLE:

import xml.sax
from xml.sax.handler import ContentHandler
class C(ContentHandler):
	def startElement(self, name, attrs):
		assert False

xml.sax.parse(xml_path, C())

Where "xml_path" points to a well-formed XML file.  This will raise an
AssertionError.  Then, attempt to modify or delete the XML file that was
specified; it's still locked by the Python process.

Deleting the ContentHandler does not unlock it.  There doesn't seem any
way to unlock it aside from terminating the Python process.

If the ContentHandler doesn't raise an exception or error, the file is
unlocked properly.
msg113251 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2010-08-08 12:14
I can't reproduce this on Windows Vista from the command line with 2.7 or py3k.  Can someone confirm that I'm correct?
msg181475 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-02-05 20:06
This is a duplicate of issue15388. Parser doesn't close an input source's stream if an exception raised.
History
Date User Action Args
2013-02-05 20:06:25serhiy.storchakasetstatus: open -> closed

superseder: SAX parse (ExpatParser) leaks file handle when given filename input

nosy: + serhiy.storchaka
messages: + msg181475
resolution: duplicate
stage: resolved
2010-08-08 12:14:36BreamoreBoysetnosy: + BreamoreBoy
messages: + msg113251
2010-06-09 22:17:09terry.reedysetversions: + Python 3.1, Python 2.7, Python 3.2, - Python 2.5
2008-05-12 19:44:33craigneurocreate