classification
Title: Pydoc interactive browser misses some docs
Type: behavior Stage:
Components: Library (Lib) Versions: Python 2.5
process
Status: closed Resolution: rejected
Dependencies: Superseder:
Assigned To: ping Nosy List: moreilcon, ping
Priority: normal Keywords:

Created on 2008-02-18 14:18 by moreilcon, last changed 2008-03-21 06:06 by ping. This issue is now closed.

Messages (2)
msg62530 - (view) Author: (moreilcon) Date: 2008-02-18 14:18
#no mention about formatdate at all:
% pydoc rfc822 | grep formatdate | wc -l
0
# but rfc822.formatdate docstring exists:
% pydoc rfc822.formatdate | wc -l
12
# also same behavior :
% pydoc codecs | getwriter | wc -l
0

Reproduced at:
Python 2.5.1 (r251:54863, Jan 17 2008, 09:20:17) 
[GCC 4.1.2 (Gentoo 4.1.2 p1.0.2)] on linux2

Python 2.5.1 (r251:54863, Oct  5 2007, 13:36:32)
[GCC 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)] on linux2

Python 2.5.1 (r251:54863, Feb 18 2008, 13:35:09)
[GCC 4.2.1 20070719  [FreeBSD]] on freebsd7
msg64233 - (view) Author: Ka-Ping Yee (ping) * (Python committer) Date: 2008-03-21 06:06
This is (currently) the intended behaviour.  The rfc822 module has an
__all__ attribute that lists its public functions and classes, so "pydoc
rfc822" only shows these things.  formatdate is not listed in __all__.

If you'd like to discuss ideas for changing this behaviour, possible
forums would be comp.lang.python or the python-dev list.
History
Date User Action Args
2008-03-21 06:06:08pingsetstatus: open -> closed
resolution: rejected
messages: + msg64233
2008-03-19 23:46:34jafosetpriority: normal
assignee: ping
nosy: + ping
2008-02-18 14:18:54moreilconcreate