classification
Title: Tests needing network flag?
Type: Stage:
Components: Versions:
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: skip.montanaro
Priority: normal Keywords:

Created on 2007-12-19 15:18 by skip.montanaro, last changed 2007-12-19 16:59 by skip.montanaro. This issue is now closed.

Files
File name Uploaded Description Edit
network.diff skip.montanaro, 2007-12-19 15:18
Messages (2)
msg58807 - (view) Author: Skip Montanaro (skip.montanaro) * Date: 2007-12-19 15:18
(third try at getting this bug report to submit by email.)

While riding to work today I ran the test suite on trunk.  The following
tests failed due to lack of network connectivity:

    test_socket
    test_socket_ssl
    test_ssl
    test_urllib2

These tests should probably either require -u network or should themselves
check to see if the network is available and skip those tests requiring
network connectivity.  In fact, regrtest.py's comments list test_socket_ssl
as requiring the network resource.  That seems to have regressed since 2.5

Simple patch attached.

Skip
msg58809 - (view) Author: Skip Montanaro (skip.montanaro) * Date: 2007-12-19 16:59
duplicate of 1659
History
Date User Action Args
2007-12-19 16:59:20skip.montanarosetstatus: open -> closed
resolution: duplicate
messages: + msg58809
2007-12-19 15:18:36skip.montanarocreate