classification
Title: py3k: readline and rlcompleter doesn't list choices
Type: Stage:
Components: Extension Modules, Library (Lib) Versions: Python 3.0
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: christian.heimes, gvanrossum
Priority: low Keywords:

Created on 2007-11-11 20:54 by christian.heimes, last changed 2008-01-06 22:29 by admin. This issue is now closed.

Messages (3)
msg57378 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2007-11-11 20:54
Python 2.5:
>>> import readline; import rlcompleter; readline.parse_and_bind("tab:
complete")
>>> import sys
>>> sys.std<tab><tab>
sys.stderr  sys.stdin   sys.stdout

Python 3.0:
>>> import readline; import rlcompleter; readline.parse_and_bind("tab:
complete")
>>> import sys
>>> import sys.std<tab><tab>
# nothing
msg57405 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2007-11-12 17:25
Can't reproduce this (Ubuntu dapper). I get the expected output.
msg57408 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2007-11-12 17:27
Fixed in r58941 (trunk), r58947 (merge) and r58933
History
Date User Action Args
2008-01-06 22:29:45adminsetkeywords: - py3k
versions: Python 3.0
2007-11-12 17:27:55christian.heimessetstatus: open -> closed
resolution: fixed
messages: + msg57408
2007-11-12 17:25:42gvanrossumsetnosy: + gvanrossum
messages: + msg57405
2007-11-11 22:39:43christian.heimeslinkissue1425 superseder
2007-11-11 20:54:45christian.heimescreate