classification
Title: PyUnicode_FromFormatV: support width and precision for string codes, e.g %S and %R
Type: enhancement Stage:
Components: Interpreter Core Versions: Python 3.3
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: haypo, petri.lehtinen
Priority: normal Keywords:

Created on 2011-11-18 11:58 by petri.lehtinen, last changed 2011-11-18 12:03 by haypo. This issue is now closed.

Messages (2)
msg147858 - (view) Author: Petri Lehtinen (petri.lehtinen) * (Python committer) Date: 2011-11-18 11:58
Currently, the width and precision information for string codes are accepted but ignored. They should be used to pad short strings (width) and truncate long ones (precision), just like printf() (only in terms of code points rather than bytes, since those codes work with Unicode text).
msg147860 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2011-11-18 12:03
Duplicate of #7330.
History
Date User Action Args
2011-11-18 12:03:21hayposetstatus: open -> closed

nosy: + haypo
messages: + msg147860

resolution: duplicate
2011-11-18 11:58:54petri.lehtinencreate