classification
Title: Packaging cannot install resource directory trees specified in setup.cfg
Type: behavior Stage: resolved
Components: Distutils2, Library (Lib) Versions: Python 3.3, 3rd party
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: eric.araujo Nosy List: alexis, eric.araujo, tarek, vinay.sajip
Priority: normal Keywords: easy

Created on 2011-11-03 11:50 by vinay.sajip, last changed 2014-03-12 10:24 by eric.araujo. This issue is now closed.

Messages (3)
msg146917 - (view) Author: Vinay Sajip (vinay.sajip) * (Python committer) Date: 2011-11-03 11:50
If setup.cfg contains a line such as

[files]
resources =
    mydata/** = {purelib}

and the project contains a directory tree more than one level deep under mydata, e.g.

mydata
 |
 +-mydata1
 |   |
 |   +-data1.dat
 |
 +-mydata2
     |
     +-data2.dat

then the parsing correctly identifies all the things to copy, but the install_data step fails because it does not try to create intermediate directories for mydata1, mydata2 but tries to copy them as files using copy_file.
msg146941 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-11-03 16:02
Should be easy to add a test to reproduce this.
msg213239 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2014-03-12 10:24
This is an issue for d2to1 / pbr / a new wheel PEP.
History
Date User Action Args
2014-03-12 10:24:44eric.araujosetstatus: open -> closed
resolution: out of date
messages: + msg213239

stage: needs patch -> resolved
2011-11-03 16:02:06eric.araujosetpriority: high -> normal

assignee: tarek -> eric.araujo
versions: + 3rd party
keywords: + easy
type: behavior
messages: + msg146941
stage: needs patch
2011-11-03 11:50:55vinay.sajipcreate