classification
Title: py3k: compilation with VC2005
Type: compile error Stage:
Components: Windows Versions: Python 3.0
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: nnorwitz Nosy List: amaury.forgeotdarc, nnorwitz
Priority: normal Keywords:

Created on 2007-08-26 22:12 by amaury.forgeotdarc, last changed 2007-08-26 23:48 by nnorwitz. This issue is now closed.

Files
File name Uploaded Description Edit
vc2005.diff amaury.forgeotdarc, 2007-08-26 22:12
vc2005-2.diff amaury.forgeotdarc, 2007-08-26 23:09
Messages (7)
msg55315 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2007-08-26 22:12
This patch is necessary to compile inside the PCBuild8 directory
msg55316 - (view) Author: Neal Norwitz (nnorwitz) * (Python committer) Date: 2007-08-26 23:04
Thanks for the patch.  I tried to apply this patch, but almost
everything failed.  Could you make sure to do a svn update and then
generate the patch?

The only part of the patch that applied cleanly was to rmpyc.py.  That
was checked in as:
Committed revision 57527.
msg55319 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2007-08-26 23:09
Sorry, it's probably because I somehow converted the line endings.
Attached a new version of the patch.
msg55320 - (view) Author: Neal Norwitz (nnorwitz) * (Python committer) Date: 2007-08-26 23:16
Hmmm, the patch was out of date (I had already removed cPickle). 
However, I don't think that was the reason for everything failing.  I
manually applied the changes to the files and python version.  Things
should be pretty good now.  I didn't add the libraries.  I'm not sure
why they are needed now while they weren't necessary before.  

Committed revision 57529.
msg55322 - (view) Author: Neal Norwitz (nnorwitz) * (Python committer) Date: 2007-08-26 23:21
I thought it might be line endings so I tried changing them, but that
didn't help.  I couldn't apply the new version of the patch either.  I'm
not sure if the problem is on your side or mine. :-(

I missed some files from the original checkin.  The new one hopefully
has all the files and is just missing the libraries.  Can you svn update
and look at the new differences?  Thanks.

Committed revision 57530.
msg55326 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2007-08-26 23:43
Yes, everything compiles now.
I discovered that the additional libraries not necessary if I update my
VC 2005 Express installation as in this post:
http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=133236&SiteID=1

> The problem is that the default installation of VS 8 express 
> doesn't support the Platform SDK, so, after installing the 
> platform SDK, you need to make a few modifications...
> 
> 1. Update the corewin_express.vsprops file (NOT the 
> corewin.vsprops file).
(In the c:/Program Files/Microsoft Visual Studio 8/VC/VCProjectDefaults/
 directory)
> You need to change this...
> 
> AdditionalDependencies="kernel32.lib"
> 
> to this
> 
> AdditionalDependencies="kernel32.lib user32.lib gdi32.lib winspool.lib
comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib"
>

And everything compiles fine without further modification. Thanks!
msg55327 - (view) Author: Neal Norwitz (nnorwitz) * (Python committer) Date: 2007-08-26 23:48
Awesome!  I'm going to close this patch.  Let me know if you have any
more problems.  Feel free to send messages to python-3000.  I would like
py3k to build on Windows for the alpha which will be coming out in about
a week hopefully.
History
Date User Action Args
2007-08-26 23:48:22nnorwitzsetstatus: open -> closed
assignee: nnorwitz
resolution: fixed
messages: + msg55327
2007-08-26 23:43:34amaury.forgeotdarcsetmessages: + msg55326
2007-08-26 23:21:47nnorwitzsetmessages: + msg55322
2007-08-26 23:16:44nnorwitzsetmessages: + msg55320
2007-08-26 23:09:53amaury.forgeotdarcsetfiles: + vc2005-2.diff
messages: + msg55319
2007-08-26 23:04:34nnorwitzsetnosy: + nnorwitz
messages: + msg55316
2007-08-26 22:12:08amaury.forgeotdarccreate