Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code | Sign in
(147879)

#26662: configure/Makefile doesn't check if "python" command works, needed to build Objects/typeslots.inc

Can't Edit
Can't Publish+Mail
Start Review
Created:
2 years, 8 months ago by vstinner
Modified:
2 years, 8 months ago
Reviewers:
vadmium+py
CC:
haypo, xdegaye, devnull_psf.upfronthosting.co.za, Martin Panter, koobs, Chi Hsuan Yen
Visibility:
Public.

Patch Set 1 #

Patch Set 2 #

Total comments: 1

Patch Set 3 #

Patch Set 4 #

Unified diffs Side-by-side diffs Delta from patch set Stats Patch
configure View 1 2 3 4 chunks +51 lines, -104 lines 0 comments Download
configure.ac View 1 2 3 2 chunks +8 lines, -17 lines 0 comments Download
Makefile.pre.in View 1 2 3 5 chunks +5 lines, -4 lines 0 comments Download
Objects/typeslots.py View 1 2 3 1 chunk +38 lines, -26 lines 0 comments Download

Messages

Total messages: 1
Martin Panter
2 years, 8 months ago #1
https://bugs.python.org/review/26662/diff/17900/configure.ac
File configure.ac (right):

https://bugs.python.org/review/26662/diff/17900/configure.ac#newcode62
configure.ac:62: PYTHON_FOR_GEN="@echo -e \"Cannot generate \$@, python not
found !\n\
echo -e is not portable. E.g. it is printed literally when using the Dash shell.

The most obvious solution would be to use multiple “echo” commands (or use
“printf”, or make the message a single line)

Also, I’m not very familiar with the intricacies of the configure.ac syntax, but
in plain shell syntax you can use single quotes (') to avoid the escaping:

PYTHON_FOR_GEN='@echo "Cannot generate $@, . . ." && . . .'
Sign in to reply to this message.

RSS Feeds Recent Issues | This issue
This is Rietveld 894c83f36cb7+