This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author coutinhotiago
Recipients coutinhotiago, theller
Date 2009-07-31.15:13:36
SpamBayes Score 9.50387e-10
Marked as misclassified No
Message-id <>

It seems that the ctypes.PyThreadState_SetAsyncExc is not working in
Linux 64bits machines

I have tried the code in attachment in python 2.5 and 2.6 in both 32bits
and 64bits machines with the following return:

      | linux 32bits | linux 64bits |
py2.5 |     1 (OK)   |     0 (ERR)  |
py2.6 |     1 (OK)   |     0 (ERR)  |

I have also tried to make a python extension in C++ exporting a function
to python that simply calls the C++ PyThreadState_SetAsyncExc and this
works fine.
Date User Action Args
2009-07-31 15:13:44coutinhotiagosetrecipients: + coutinhotiago, theller
2009-07-31 15:13:43coutinhotiagosetmessageid: <>
2009-07-31 15:13:40coutinhotiagolinkissue6613 messages
2009-07-31 15:13:38coutinhotiagocreate