Author squeegee
Recipients JosephArmbruster, astrand, christian.heimes, ggenellina, joearmbruster, squeegee
Date 2009-07-04.04:19:05
SpamBayes Score 2.55889e-09
Marked as misclassified No
Message-id <1246681148.08.0.888988788738.issue1475@psf.upfronthosting.co.za>
In-reply-to
Content
(Same comment I added to 1559298:)
What is needed is separate quoting for the command and the argument. 
Right now, test_popen only surrounds the entire command line with quotes:

"c:\Program Files\Python2.6\Python.exe -u c:\Documents and Settings\Russ
Gibson\cgi-bin\cgi.py"

It needs to test the above as thus:

"c:\Program Files\Python2.6\Python.exe" -u "c:\Documents and
Settings\Russ Gibson\cgi-bin\cgi.py"

From the command line, the second case works, but the first doesn't.
Neither work from os.popen in 2.6.2.  I have been unable to get popen*
to work with a command and an argument that both contain spaces.

To make sure that popen works in all cases under windows, test_popen*
needs to test with separate quotes around the command and argument. 
That will show the real problem with the current os.popen*
implementation(s).

(yeah, I know, shut up and provide a patch...)
History
Date User Action Args
2009-07-04 04:19:08squeegeesetrecipients: + squeegee, astrand, ggenellina, joearmbruster, christian.heimes, JosephArmbruster
2009-07-04 04:19:08squeegeesetmessageid: <1246681148.08.0.888988788738.issue1475@psf.upfronthosting.co.za>
2009-07-04 04:19:05squeegeelinkissue1475 messages
2009-07-04 04:19:05squeegeecreate