This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author sirgimp
Recipients roger.serwy, sirgimp
Date 2009-06-02.02:29:15
SpamBayes Score 1.8945e-10
Marked as misclassified No
Message-id <1243909749.6510.63.camel@jason-desktop>
In-reply-to <1243904031.88.0.967637860733.issue6168@psf.upfronthosting.co.za>
Content
Again, thanks for your prompt explanation.

It's odd, but when I went to use Ubuntu's menu modification tool, the
command displayed in the dialog didn't show the -n option.

But when I added the Python launcher to the panel and viewed the launch
command via the properties dialog, the -n was there and I was easily
able to remove it. 

So if I run Python from the modified icon in the panel, it launches
without the -n option. But if I run it from the Application Menu, it
runs without the -n option. It seems to me that the -n option should be
available when viewing it from the menu modification tool, but it's not.

I guess Windows doesn't have this problem with running IDLE with a
subprocess. I was able to run several instances of the IDLE shell with
the Shell menu displayed.

On Tue, 2009-06-02 at 00:53 +0000, Roger Serwy wrote:

> Roger Serwy <roger.serwy@gmail.com> added the comment:
> 
> You'll need to modify the IDLE menu item to remove the "-n" using
> Ubuntu's menu modification tool, usually found under System->Preferences.
> 
> Presently, using a subprocess only allows for one instance of IDLE
> running on a machine, whereas running with no subprocess allows for many
> instances of IDLE. This architecture is by design.
> 
> Check out Ubuntu bug 338379.
> 
> ----------
> 
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue6168>
> _______________________________________
Files
File name Uploaded
unnamed sirgimp, 2009-06-02.02:29:14
History
Date User Action Args
2009-06-02 02:29:18sirgimpsetrecipients: + sirgimp, roger.serwy
2009-06-02 02:29:15sirgimplinkissue6168 messages
2009-06-02 02:29:15sirgimpcreate