This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author Nick Barnes
Recipients Nick Barnes, ggenellina, lemburg, pitrou, vstinner
Date 2009-05-04.16:34:34
SpamBayes Score 1.17839e-12
Marked as misclassified No
Message-id <>
This was my first contribution to Python.  I don't know what the rules
are on changing the arguments of an internal function such as
PyUnicode_EncodeUTF7().  Since I was rewriting the whole function
anyway, I tried to give it arguments which made more sense with respect
to the defining RFC.  If you want us to revert to the original meanings
of these arguments (so the third argument means "use base-64 encoding
for characters in set O", and not "use direct encoding for characters in
set O"), please can we have better names for them?

The name "encodeSetO" was meaningless: the function encodes *all* the
characters in the string.  What the argument specifies is whether the
"set O" characters are self-encoded or base-64 encoded.  So maybe it
should be called "base64SetO".

Ditto for the "encodeWhiteSpace" name.

Here's a trunk patch with the meaning of those parameters reverted, and
better names.
Date User Action Args
2009-05-04 16:34:36Nick Barnessetrecipients: + Nick Barnes, lemburg, ggenellina, pitrou, vstinner
2009-05-04 16:34:36Nick Barnessetmessageid: <>
2009-05-04 16:34:35Nick Barneslinkissue4426 messages
2009-05-04 16:34:34Nick Barnescreate