Author gvanrossum
Recipients benjamin.peterson, giampaolo.rodola, gpolo, gregory.p.smith, gvanrossum, michael.foord, ncoghlan, pitrou, pupeno, purcell, rhettinger, skip.montanaro
Date 2009-04-02.16:40:00
SpamBayes Score 0.00010726
Marked as misclassified No
Message-id <ca471dc20904020939u7b75aebbg4679fa3aac508bf@mail.gmail.com>
In-reply-to <1238675803.13.0.46679608307.issue2578@psf.upfronthosting.co.za>
Content
> Nick Coghlan <ncoghlan@gmail.com> added the comment:
> Bikeshedding a bit - the 'assertGreaterEqual' and 'assertLessEqual'
> method names grate on me a little. My brain has to do a double take in
> order to correctly insert the implied 'Or'. This reaction is made worse
> when these two methods are juxtaposed with all the other "assert*Equal"
> methods like DictEqual, ListEqual, SetEqual etc.
>
> Would it be possible to lengthen these specific names to the more
> explicit "assertGreaterOrEqual" and "assertLessOrEqual"?

No, please. Get used to it. Maybe it helps if you realize the parallel
with '__ge__'?
History
Date User Action Args
2009-04-02 16:40:03gvanrossumsetrecipients: + gvanrossum, skip.montanaro, rhettinger, gregory.p.smith, purcell, ncoghlan, pitrou, giampaolo.rodola, pupeno, benjamin.peterson, gpolo, michael.foord
2009-04-02 16:40:00gvanrossumlinkissue2578 messages
2009-04-02 16:40:00gvanrossumcreate