Author doko
Recipients benjamin.peterson, bgomes, christian.heimes, doko, draghuram, georg.brandl, lemburg, pavel.vinogradov, sapetnioc, zooko
Date 2009-03-18.17:13:29
SpamBayes Score 0.000772016
Marked as misclassified No
Message-id <1237396411.15.0.309007084271.issue1322@psf.upfronthosting.co.za>
In-reply-to
Content
MAL, please can we add zooko's patch in some form? The current
implementation assumes an implementation, which doesn't exist on all
platforms, and just dividing linux distributions in "unsupported" and
"supported" seems to be odd.

You cite some URL's in platform.py:

 - http://linuxmafia.com/faq/Admin/release-files.html
 
   "Linux System Base-compliant systems should have a file called
   /etc/lsb_release, which may be in addition to a distribution-
   specific file."

   The standard doesn't say anything like this.

 - http://linux.die.net/man/1/lsb_release
   This is one implementation, not more. The current platform.py
   implementation seems to require this particular implementation.

The only relevant URL is missing in this file:
http://refspecs.freestandards.org/LSB_3.2.0/LSB-Core-generic/LSB-Core-generic/lsbrelease.html
History
Date User Action Args
2009-03-18 17:13:31dokosetrecipients: + doko, lemburg, georg.brandl, zooko, draghuram, christian.heimes, sapetnioc, benjamin.peterson, pavel.vinogradov, bgomes
2009-03-18 17:13:31dokosetmessageid: <1237396411.15.0.309007084271.issue1322@psf.upfronthosting.co.za>
2009-03-18 17:13:30dokolinkissue1322 messages
2009-03-18 17:13:29dokocreate