Author Thorney
Recipients Thorney
Date 2008-12-03.21:58:53
SpamBayes Score 4.07473e-10
Marked as misclassified No
Message-id <1228341537.43.0.522254260997.issue4508@psf.upfronthosting.co.za>
In-reply-to
Content
I found this bug when using scipy's weave and having some inline C/C++
code. Weave uses distutils to compile the source in its own directory,
python was installed under "program files". Unfortunately it doesn't
seem to handle spaces in the path to either the output or the temporary
source files.
I checked that this was the only problem by copying the weave directory
from site-packages and put it in another directory without spaces in the
path - weave and distutils then worked fine.
I then tried the g++ command seen in the stack trace at the command line
and got the same error - so altered the command by correctly quoting the
 -c "path/to source/a.c" and the -o objects.
This worked so set out changing it in distutils.

The two files I altered were unixcompiler.py (surprising as I am under
windows!) and cygwinccompiler.py 

This was clearly an older stable build so I checked out the python trunk
r67510 on windows (32bit), made a patch, and tested with my weave
dependant code.
(I am not familiar enough with distutils to make a standalone test).

The same method to cause a problem has the same effect in ubuntu - the
build directory seems to default to users home, but as the source path
has a space in it g++ gets confused.
History
Date User Action Args
2008-12-03 21:58:57Thorneysetrecipients: + Thorney
2008-12-03 21:58:57Thorneysetmessageid: <1228341537.43.0.522254260997.issue4508@psf.upfronthosting.co.za>
2008-12-03 21:58:55Thorneylinkissue4508 messages
2008-12-03 21:58:54Thorneycreate