This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author skip.montanaro
Recipients skip.montanaro
Date 2008-10-11.03:30:18
SpamBayes Score 3.8400806e-08
Marked as misclassified No
Message-id <>
I worked up a simple example of using the external processing module 
(0.52) for a friend at work today.  I noticed some cases where it raised 
exceptions during exit.  Not all the time, but not infrequently either.  
This evening I tweaked it for the 2.6 multiprocessing module's API and 
tried it out.  I ran it in a large loop:

   for i in $(range 500) ; do
       echo '!'$i
   end | egrep '!'

Most of the time all I see are the '!' lines from the echo command.  
Every once in awhile I see a traceback though.  For example:

Exception in thread QueueFeederThread (most likely raised during 
interpreter shutdown):
Traceback (most recent call last):
  File "/Users/skip/local/lib/python2.7/", line 522, in 
  File "/Users/skip/local/lib/python2.7/", line 477, in run
  File "/Users/skip/local/lib/python2.7/multiprocessing/", line 
233, in _feed
<type 'exceptions.TypeError'>: 'NoneType' object is not callable

This occurred once in approximately 1500 runs of the script (three times 
through the above shell loop).  The script used to trigger this 
exception is attached.
Date User Action Args
2008-10-11 03:30:22skip.montanarosetrecipients: + skip.montanaro
2008-10-11 03:30:22skip.montanarosetmessageid: <>
2008-10-11 03:30:21skip.montanarolinkissue4106 messages
2008-10-11 03:30:20skip.montanarocreate